cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Visitor
Visitor
4,236 Views
Registered: ‎01-20-2009

execuiting do file

Jump to solution

I'm using ISE 10.1.03 and ModelSim XE 6.3c.

I've written a do file. It works well. But whenever I run ModelSim, it runs default wave window. So to load my do file I've to issue do command do.

However I do not want to do it again and again. So How do I change this default wave window settings?

 

I've seen "pref.tcl"  and "modelsim.ini" but coudn't understand what to modify?

 

Pl. help me.

 

 

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Xilinx Employee
Xilinx Employee
4,993 Views
Registered: ‎08-15-2007

Re: execuiting do file

Jump to solution

Hello,

 

Use the "Custom DO" property in the Simulate Behavioral Model properties.  Find these properties by right-clicking on "Simualte Behavioral Model", then click Properties.

 

Remove the checkbox from "Automatic DO file" and use the "Custom DO file" property to point to your new DO file.

 

Hope this helps.

 

 

Eddie

View solution in original post

0 Kudos
2 Replies
Highlighted
Xilinx Employee
Xilinx Employee
4,994 Views
Registered: ‎08-15-2007

Re: execuiting do file

Jump to solution

Hello,

 

Use the "Custom DO" property in the Simulate Behavioral Model properties.  Find these properties by right-clicking on "Simualte Behavioral Model", then click Properties.

 

Remove the checkbox from "Automatic DO file" and use the "Custom DO file" property to point to your new DO file.

 

Hope this helps.

 

 

Eddie

View solution in original post

0 Kudos
Highlighted
Visitor
Visitor
4,212 Views
Registered: ‎01-20-2009

Re: execuiting do file

Jump to solution

hi edv,

wow... it worked.

Thank you very much.

kishor

0 Kudos