cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
bradster
Visitor
Visitor
14,207 Views
Registered: ‎07-21-2016

fatal error: memory.h: No such file or directory

Hello,

 

All of a sudden my ISE fails to compile and launch ISIM when I hit 'Simulate Behaviour Model'.

 

I get the error message:

FATAL_ERROR:Simulator:Fuse.cpp:209:1.133 - Failed to compile one of the generated C files. Please recompile with -mt off -v 1 switch to identify which design unit failed.  For technical support on this issue, please visit http://www.xilinx.com/support.

 

I recompile with flag -v 1 and it looks like it can't find a particular file:

 

isim/wb_slave_reg_8_tb_isim_beh.exe.sim/work/a_0536429404_3212880686.c:17:20: fatal error: memory.h: No such file or directory
 #include <memory.h>
                    ^
compilation terminated.

 

This happens for all my projects and I have reinstalled Xilinx a couple times and I get the same result.

 

How do I go by fixing this error?

 

Thanks,

 

Brad

Engineering student

 

Environment:

  • Xilinx ISE 14.7 (lin64)
  • Linux Mint Rosa (64 bit, Trusty)
  • 16 GB RAM
  • Intel Core i5-2320

*************************************
* Software Environment:
*************************************
Default Web Browser: netscape
SUDO_GID: 1000
MAIL: /var/mail/root
USER: root
LD_LIBRARY_PATH: /home/brad/Downloads/Xilinx_ISE_DS_Lin_14.7_1015_1//lib/lin64:./bin/lin64/bin/lin64
HOME: /home/brad
COLORTERM: xfce4-terminal
SUDO_UID: 1000
LOGNAME: root
TERM: xterm
USERNAME: root
PATH: /home/brad/Downloads/Xilinx_ISE_DS_Lin_14.7_1015_1//bin/lin64:/usr/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/sbin:/bin
DISPLAY: :0.0
XAUTHORITY: /home/brad/.Xauthority
SUDO_COMMAND: ./xinfo
SHELL: /bin/bash
SUDO_USER: brad
PWD: /home/brad/Downloads/Xilinx_ISE_DS_Lin_14.7_1015_1
XILINX: /home/brad/Downloads/Xilinx_ISE_DS_Lin_14.7_1015_1/

 

 

 

Tags (3)
0 Kudos
8 Replies
syedz
Moderator
Moderator
14,203 Views
Registered: ‎01-16-2013

@bradster,

 

Try deleting the temporary project files and relaunch the simulation.

In ISE GUI, Select project-->Clean up Project files..

 

Also check if the following AR or thread helps:

http://www.xilinx.com/support/answers/55423.html

 

https://forums.xilinx.com/t5/General-Technical-Discussion/xilinx-14-2-bug-in-ubuntu/td-p/258516

 

https://forums.xilinx.com/t5/Simulation-and-Verification/Can-not-execute-bihavioral-simulation-on-ISE/m-p/554779

 

--Syed

---------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.

Did you check our new quick reference timing closure guide (UG1292)?
---------------------------------------------------------------------------------------------
0 Kudos
balkris
Xilinx Employee
Xilinx Employee
14,193 Views
Registered: ‎08-01-2008

Solution 1



This fatal error might occur due to an unexpected condition while compiling the sources of your design.

It might be possible to work around this fatal error by reviewing details of the fatal error.

You can learn more about the nature of the fatal crash by enabling verbose debugging messages from the compiler.

Using these messages, you can learn whether modifications to your source code can resolve the fatal error.

Enabling Verbose Messaging :

If using ISE Project Navigator:
 
Add the switch "-v 1" in the Other Compiler Options property name, under the Simulate Behavioral/Post Place and Route Model properties (make sure the Property Display Level in this property window is set to Advanced).

If using a batch file:
 
Add "-v 1" to the fuse command.

Please help us address this issue in a future update of the ISE Design Suite tools by informing Xilinx Technical Support of the issue.

Contact information can be found at: http://www.xilinx.com/support/techsup/tappinfo.htm

Solution 2



By default, the ISE Simulator compiler (fuse) uses multi-threading when compiling design sources.

A fatal error might occur due to an unexpected compilation error while multi-threading is enabled.

It might be possible to work around this fatal error by disabling multi-threading.

Disabling Multi-Threading

If using ISE Project Navigator:
Add the switch "-mt off" in the Other Compiler Options property name. Under the Simulate Behavioral/Post Place and Route Model properties, make sure the Property Display Level in this property window is set to Advanced.

If using a batch file:
Add "-mt off" to the fuse command line.

Refer to the ISim Help documentation for information on multi-threading.
Please help Xilinx address this issue in a future update of the ISE Design Suite tools by informing Technical Support of the issue.

Solution 3



This fatal error can occur if the ISim compiler (fuse) is being run on an unsupported operating system.
Check whether your operating system is supported by visiting the ISE Operating System Support Page at: http://www.xilinx.com/ise/ossupport/#simulator

Solution 4



This fatal error can occur if the ISim compiler (fuse) is launched using a DOS-formatted batch file in a Linux environment.
Certain DOS carriage return characters can cause the ISim compiler to fail.

Solution 5



This is a known issue with ISim in ISE Design Suite 11.1 tools and it has been fixed in ISE Design Suite 11 Update 2 (11.2).
Please download and install the latest ISE Design Suite version from the Download Center at: http://www.xilinx.com/support/download/index.htm

Solution 6



This fatal error can occur if the GNU Compiler (GCC) is missing or has not been installed on your machine.
Use verbose messaging (as shown in Solution 1) to learn whether there are errors issued when ISim attempts to launch GCC.
The fatal error can also occur if certain GCC-specific system environment variables are set.

Refer to (Xilinx Answer 33845) for more information on how to identify and resolve this issue.

Solution 7



This fatal error can occur when compiling some designs that require a large amount of memory (~2GB) on a 32-bit system.
Please monitor the memory usage of the ISim compiler (fuse).
If a large amount of memory is used prior to the fatal crash, please simulate the design on a supported 64-bit environment.

This issue is currently under investigation in order to better address this condition in a future release of the ISE Simulator.
Please inform Xilinx Technical Support of the issue by contacting them at: http://www.xilinx.com/support/techsup/tappinfo.htm

Solution 8



This fatal error can occur if the $timeformat Verilog system task is used in the design.

This issue has been fixed in ISE Design Suite 11 Update 2 (11.2).
Please download and install the latest ISE Design Suite update from the Download Center at: http://www.xilinx.com/support/download/index.htm.

Solution 9



This fatal error can occur if there are unconstrained ports in an entity.

For example:

Port ( S : in STD_LOGIC_VECTOR;
A : out STD_LOGIC_VECTOR(n-1 downto 0);
B : out STD_LOGIC_VECTOR(n-1 downto 0);
C : out STD_LOGIC_VECTOR(n-1 downto 0);


Adding "(n-1 downto 0)" to the S port above resolves the fatal error.

Thanks and Regards
Balkrishan
--------------------------------------------------------------------------------------------
Please mark the post as an answer "Accept as solution" in case it helped resolve your query.
Give kudos in case a post in case it guided to the solution.
0 Kudos
bradster
Visitor
Visitor
14,191 Views
Registered: ‎07-21-2016

Hi,

 

I've come across this thread before I posted... None of them helped unfortunately.

 

It does say that it could be an unsupported OS - but I don't think this is the problem as I was able to simulate on my machine a couple days ago.

0 Kudos
bradster
Visitor
Visitor
14,189 Views
Registered: ‎07-21-2016

Hi,

 

Cleaning up project files doesn't fix the problem. Even new, simple projects fail to compile.

 

I've already viewed the first and third links before posting.

 

The second link seems to say I need to install an older version of gcc... guess I'll give that a go.

 

Thanks

0 Kudos
syedz
Moderator
Moderator
14,188 Views
Registered: ‎01-16-2013

@bradster,

 

What is the OS you are using with ISE? If it was working previously then please check if you have installed any new software which might be causing this issue.

 

--Syed

---------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.

Did you check our new quick reference timing closure guide (UG1292)?
---------------------------------------------------------------------------------------------
0 Kudos
bradster
Visitor
Visitor
14,182 Views
Registered: ‎07-21-2016

Linux Mint Rosa 64bit (ubuntu 14.04 Trusty)
0 Kudos
syedz
Moderator
Moderator
14,163 Views
Registered: ‎01-16-2013

@bradster.

 

Ubuntu is unsupported OS with ISE hence it may give you such unusual results. Please see the below AR to know the list of supported OS with ISE.

http://www.xilinx.com/support/answers/18419.html

 

I would strongly recommended you to use any one of the supported OS to overcome this issue.

 

--Syed

---------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.

Did you check our new quick reference timing closure guide (UG1292)?
---------------------------------------------------------------------------------------------
0 Kudos
f_point
Newbie
Newbie
13,527 Views
Registered: ‎09-03-2016

Hello,

 

I recently had this same issue when using Linux Mint Sarah (64 bit) and I think I may be a couple months late, but if this is still useful for someone, I'll explain how I fixed this.

 

Isim uses your operating system's toolchain in order to compile the simulations. The aforementioned "memory.h" file is part of the regular C header files that come with the standard libraries. You can supply this file by installing the build-essentials package, using this comand:

 

sudo apt-get install build-essential

After this simply cleanup the project files and retry a simulation run. I had an additional issue where ise didn't find an object file and it cleared after deleting the isim directory iside the project directory (this doesn't get deleted by selecting "project->cleanup project files" from the menu).

 

 

Hope this helps.

0 Kudos