UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Explorer
Explorer
176 Views
Registered: ‎10-12-2018

send_tready() hangs using AXI-Stream VIP

Jump to solution

Hi,

I use AXI4-Stream VIP for simulation. I want to generate NO backpressure, so I want to assert the tready all the time at slave VIP.

Here is a snippet of my simulation:

 

axi4stream_ready_gen    ready_gen;
axis_vip_slave_slv_t   s_axis_agent;

s_axis_agent = new("s_axis_agent", sim_top.DUT_tb.inst_axis_vip_x0y4_slv.inst.IF);
      
s_axis_agent.start_slave();

// Generate NO backpressure
ready_gen = s_axis_agent.driver.create_ready("ready_gen00");
ready_gen.set_ready_policy(XIL_AXI4STREAM_READY_GEN_NO_BACKPRESSURE);
s_axis_agent.driver.send_tready(ready_gen);
      

The last statement: send_tready() doesn't return at all. Why?

I use:

  • Win 10
  • Vivado 2017.4
0 Kudos
1 Solution

Accepted Solutions
Explorer
Explorer
158 Views
Registered: ‎10-12-2018

Re: send_tready() hangs using AXI-Stream VIP

Jump to solution

Finally I found that the VIP was in reset state.

(I still cannot understand why it cannot set the tready policy in reset state...)

0 Kudos
1 Reply
Explorer
Explorer
159 Views
Registered: ‎10-12-2018

Re: send_tready() hangs using AXI-Stream VIP

Jump to solution

Finally I found that the VIP was in reset state.

(I still cannot understand why it cannot set the tready policy in reset state...)

0 Kudos