UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Participant barrygmoss
Participant
1,789 Views
Registered: ‎03-20-2018

set_property display_limit not allowing for large objects to be displayed (Vivado 2018.1)

Jump to solution

I'm wanting to observe some large testbench objects in the waveform viewer. Specifically an object like tx_views:

 

localparam integer    TESTCASE_VIEWS = 2;

localparam bit [12:0] VD_BUFFER_SIZE = 15'd3456; 

....

bit [127:0] tx_views [TESTCASE_VIEWS-1:0][VD_BUFFER_SIZE-1:0];

 

So the size of the object is 2 * 3456 * 128 = 884,736 bits. So I'll set the display_limit to 1,000,000 just to allow for some overhead or in case I make a small change to the VD_BUFFER_SIZE later. And just to be sure, I read back the property to check my syntax in increasing the value was done correctly:

 

set_property display_limit 1000000 [current_wave_config]

get_property display_limit [current_wave_config]
1000000

 

However, even after all this was done, I can't see to add the large object to my display window. I applied this changes after the simulation had been initialized and run for 1 us. 

 

I hypothesized that I might need to restart the simulation for the new display_limit to take effect, but when I do that the display_limit is reset to the default:

 

get_property display_limit [current_wave_config]
65536

 

So I'm left wondering, how do I get the display_limit to properly allow me to add large objects to the waveform viewer, or have I had some limit so the command fails without an error message?

 

Further, once I can get it working properly, how can I make this property persistent so I don't need to reset it every time I restart my simulation? 

 

P.S. I've also tried making the array completely packed, but that didn't help either. 

 

 

0 Kudos
1 Solution

Accepted Solutions
Xilinx Employee
Xilinx Employee
1,736 Views
Registered: ‎07-16-2008

Re: set_property display_limit not allowing for large objects to be displayed (Vivado 2018.1)

Jump to solution

When I launched simulation and firstly tried to add the vector to wave, I received this warning.

 

add_wave {{/ODMB_vfp_tb/tx_views}}
WARNING: [Wavedata 42-489] Can't add object "/ODMB_vfp_tb/tx_views" to the wave window because it has 884736 bits, which exceeds the display limit of 65536 bits. To change the display limit, use the command "set_property display_limit <new limit> [current_wave_config]".

 

After setting a new limit to the wave config, I was able to add it to wave but no value is shown.

You need to quit simulation and set the following additional properties to have it correctly logged and displayed.

set_property xsim.array_display_limit 1000000 [current_project]
set_property xsim.trace_limit 1000000 [current_project]

 

Then launch simulation and set display_limit.

set_property display_limit 1000000 [current_wave_config]

 

You can then add it to wave and view the value in waveform.

-------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
11 Replies
Highlighted
Scholar dpaul24
Scholar
1,764 Views
Registered: ‎08-07-2014

Re: set_property display_limit not allowing for large objects to be displayed (Vivado 2018.1)

Jump to solution

@barrygmoss,

 

Did you try changing the display_limit and then *re-runing* the simulation (don't restart)?

 

Further, once I can get it working properly, how can I make this property persistent so I don't need to reset it every time I restart my simulation? 

Call simu through a TCL script where in the display_limit will be changed.

--------------------------------------------------------------------------------------------------------
FPGA enthusiast!
All PMs will be ignored
--------------------------------------------------------------------------------------------------------
Participant barrygmoss
Participant
1,735 Views
Registered: ‎03-20-2018

Re: set_property display_limit not allowing for large objects to be displayed (Vivado 2018.1)

Jump to solution
Thanks for the suggestion. Hitting the relaunch button instead of restart does indeed preserve the value of the property.

However, the set_property still doesn't seem to allow me to add large objects (as I mentioned in my original post) to the waveform.
0 Kudos
Xilinx Employee
Xilinx Employee
1,724 Views
Registered: ‎07-16-2008

Re: set_property display_limit not allowing for large objects to be displayed (Vivado 2018.1)

Jump to solution

Are you able to see the vector in Objects window?

Did you receive any message when you tried to add it to wave?

-------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
Participant barrygmoss
Participant
1,710 Views
Registered: ‎03-20-2018

Re: set_property display_limit not allowing for large objects to be displayed (Vivado 2018.1)

Jump to solution

The vector is visible in the Object window. There are no messages in the Tcl Console or the Messages window when I attempt to add it to the wave by dragging it to the waveform window. 

0 Kudos
Xilinx Employee
Xilinx Employee
1,703 Views
Registered: ‎07-16-2008

Re: set_property display_limit not allowing for large objects to be displayed (Vivado 2018.1)

Jump to solution

If you see vector value truncated, try setting the below property.

set_property array_display_limit <bits> [current_sim]

-------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
Participant barrygmoss
Participant
1,699 Views
Registered: ‎03-20-2018

Re: set_property display_limit not allowing for large objects to be displayed (Vivado 2018.1)

Jump to solution

I gave that a try, but sadly, it's still failing. The vector isn't truncated, it just doesn't show up in the simulation window at all when I drag it over (where as much shorter vectors will appear).

0 Kudos
Xilinx Employee
Xilinx Employee
1,694 Views
Registered: ‎07-16-2008

Re: set_property display_limit not allowing for large objects to be displayed (Vivado 2018.1)

Jump to solution

Do you see all bits shown up in the Objects window?

If possible, please attach the project archive for a look.

-------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
Participant barrygmoss
Participant
1,682 Views
Registered: ‎03-20-2018

Re: set_property display_limit not allowing for large objects to be displayed (Vivado 2018.1)

Jump to solution

Here's a screen shot of some of the larger items in my objects window. It looks correct: 

 

Vivado simulation objects.png

 

I'm happy to provide a design archive. Is there some way I can do that without posting it publicly?

 

Barry

0 Kudos
Xilinx Employee
Xilinx Employee
1,673 Views
Registered: ‎07-16-2008

Re: set_property display_limit not allowing for large objects to be displayed (Vivado 2018.1)

Jump to solution

Please message me with your email address and I'll send you an EzMove (a file transfer application) link to upload the design.

-------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
Xilinx Employee
Xilinx Employee
1,737 Views
Registered: ‎07-16-2008

Re: set_property display_limit not allowing for large objects to be displayed (Vivado 2018.1)

Jump to solution

When I launched simulation and firstly tried to add the vector to wave, I received this warning.

 

add_wave {{/ODMB_vfp_tb/tx_views}}
WARNING: [Wavedata 42-489] Can't add object "/ODMB_vfp_tb/tx_views" to the wave window because it has 884736 bits, which exceeds the display limit of 65536 bits. To change the display limit, use the command "set_property display_limit <new limit> [current_wave_config]".

 

After setting a new limit to the wave config, I was able to add it to wave but no value is shown.

You need to quit simulation and set the following additional properties to have it correctly logged and displayed.

set_property xsim.array_display_limit 1000000 [current_project]
set_property xsim.trace_limit 1000000 [current_project]

 

Then launch simulation and set display_limit.

set_property display_limit 1000000 [current_wave_config]

 

You can then add it to wave and view the value in waveform.

-------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
Participant barrygmoss
Participant
1,297 Views
Registered: ‎03-20-2018

Re: set_property display_limit not allowing for large objects to be displayed (Vivado 2018.1)

Jump to solution
Thanks! I've got it going now.
0 Kudos