UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Contributor
Contributor
1,756 Views
Registered: ‎09-02-2008

viv2018.2 issue compiling modelsim libraries in Linux

Jump to solution

* Fresh 2018.2 install in Ubuntu 16.04.4 LTS.

* Modelsim DE 10.6b is installed and has been working fine with viv2017.3 compiled libraries.

* Here's the error I get:

 

start_gui
compile_simlib -simulator modelsim -simulator_exec_path {/opt/mentor/modelsim_dlx/bin} -family kintexu -language vhdl -library all -dir {/home/Xilinx_sim_libs/viv2018p2}
WARNING: [Vivado 12-5377] Language specific library compilation for IPs is not supported. By default, the libraries will be compiled for all languages.
INFO: [Vivado 12-4753] Extracting data from the IP repository...(this may take a while, please wait)...

INFO: [setup_ip_static_library-Tcl-23] Data extracted from repository. Inspected 442 IP libraries.

INFO: [Vivado 12-5496] Finding simulator executables and checking version...
ERROR: [Vivado 12-3754] Failed to find the 'modelsim' simulator executable. Make sure to set the 'modelsim' installation environment and retry this command to compile the libraries for this simulator. For more information on tool setup refer 'modelsim' user guide.
Library compilation for 'modelsim' ignored.
compile_simlib: Time (s): cpu = 00:00:55 ; elapsed = 00:00:54 . Memory (MB): peak = 6403.156 ; gain = 301.453 ; free physical = 28390 ; free virtual = 63151
ERROR: [Common 17-39] 'compile_simlib' failed due to earlier errors.
0 Kudos
1 Solution

Accepted Solutions
Xilinx Employee
Xilinx Employee
1,877 Views
Registered: ‎07-16-2008

回复: viv2018.2 issue compiling modelsim libraries in Linux

Jump to solution

Check out this answer.

https://www.xilinx.com/support/answers/67382.html

-------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------

View solution in original post

6 Replies
Contributor
Contributor
1,754 Views
Registered: ‎09-02-2008

Re: viv2018.2 issue compiling modelsim libraries in Linux

Jump to solution

I remembered that the compiled libraries I were using for Vivado 2017.3 were created on a Windows machine and copied onto my Ubuntu system.  With that in mind I tried to compile the sim libs using 2017.3 (same exact command as before).  I got the same error.

0 Kudos
Xilinx Employee
Xilinx Employee
1,740 Views
Registered: ‎11-30-2007

Re: viv2018.2 issue compiling modelsim libraries in Linux

Jump to solution

Did you setup your Vivado 2018.2 settings properly?

 

Vivado_Settings.png

 

Also, please reference the Vivado Design Suite 2018.2 Release Notes, Installation, and Licensing User Guide (UG973; v2018.2) for the supported version of 3rd Party Simulators.  In your case, it should be ModelSim 10.6c.

 

Vivado_2018_2_sim_support.png

 

0 Kudos
Highlighted
Contributor
Contributor
1,726 Views
Registered: ‎09-02-2008

Re: viv2018.2 issue compiling modelsim libraries in Linux

Jump to solution

I tried adding the Third Party Simulators fields in Settings per your recommendations.  I got the same error.

 

I checked the Compatible Third Party tools in UG973 for Vivado 2017.3 and Modelsim 10.6b is supported.  

 

viv_third_party_2017p3.PNG

 

0 Kudos
Xilinx Employee
Xilinx Employee
1,721 Views
Registered: ‎11-30-2007

Re: viv2018.2 issue compiling modelsim libraries in Linux

Jump to solution

Did you setup your ModelSim environment variable(s) properly as the ModelSim error indicates?  I assume it has to do with the modelsim.ini file as well.

0 Kudos
Xilinx Employee
Xilinx Employee
1,878 Views
Registered: ‎07-16-2008

回复: viv2018.2 issue compiling modelsim libraries in Linux

Jump to solution

Check out this answer.

https://www.xilinx.com/support/answers/67382.html

-------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------

View solution in original post

Contributor
Contributor
1,669 Views
Registered: ‎09-02-2008

回复: viv2018.2 issue compiling modelsim libraries in Linux

Jump to solution
That worked @graces. Thanks!
0 Kudos