cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Observer
Observer
1,178 Views
Registered: ‎11-13-2018

vopt switch

I'm running Vivado 2017.4 with QuestaSim 10.6a. When I export simulation, the elaborate.do file has the -64 switch on the vopt command. Is there a way to disable that? QuestaSim complains about it and I would rather not edit the generated files if I can avoid it.

0 Kudos
4 Replies
Highlighted
Xilinx Employee
Xilinx Employee
1,115 Views
Registered: ‎07-16-2008

What message did you receive from Questasim regarding the -64 switch?

-------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
Highlighted
Observer
Observer
1,105 Views
Registered: ‎11-13-2018

The error is 

** Error: (vsim-3816) Optimized design "isb_tb_opt" cannot be used by this version of the simulator - it was only compiled for a 64-bit version of vsim

my vsim command is: vsim -t 1ps -lib xil_defaultlib isb_tb_opt

if I add the -64 switch to it as follows: vsim -64 -t 1ps -lib xil_defaultlib isb_tb_opt

I get the following warning before the error mentioned above

** Warning: (vsim-159) Mode option -64 is not supported in this context and will be ignored.

 

0 Kudos
Highlighted
Xilinx Employee
Xilinx Employee
1,067 Views
Registered: ‎07-16-2008

Generally, for 64-bit modelsim toolset, the commands should work fine (vopt -64 and then vsim). 

This error indicates the optimized design failed one of several version checks. 

What if you edit the script and remove the -64 switch?

-------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
Highlighted
Observer
Observer
1,055 Views
Registered: ‎11-13-2018

Thank you for the reply. It works when I edit out the -64 switch. I can run the *.sh script the export simulate command generates; without modification; with no issue. I want to run the vsim command from the GUI in questa which is proving bothersome. If I can have vivado export the sim scripts without the -64 switch, it will make my life easier. I unable to edit the tcl command in the export sim dialog box in the GUI, where I could add the -32 switch. I am going to try to do the sim export purely in TCL, but if there was a GUI option that I could set, it would be more convenient. Again, I appreciate your help.

0 Kudos