UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor 0anubis0
Visitor
3,756 Views
Registered: ‎10-15-2016

Change XC3S200 and XCF01S to XC3S400 and XCF04S

Dear community,

I have upgraded my board FPGA to XC3S400 and the platform flash to XCF04S. It was a change on an existing board. Previously it have worked well.

http://www.xilinx.com/support/documentation/data_sheets/ds123.pdf

http://www.xilinx.com/support/documentation/user_guides/ug161.pdf

 

The problem is that, I cannot read the ID of the FPGA or the memory. The Impact said, there can be a voltage problem.

 

My tests:

-The FPGA have worked well, I have programmed it across XCF01S.

-I have checked the chips for contact problems.

 

My measurements:

-The board without initialization and memory consume 50mA. With XCF01S it consumed 70-80mA. With XCF04S, the current is only 50mA!

-I have tested the VCCJ, VCCO, VCCINT voltages, all of them was 3,3V.

 

Ideas:

-So the memory have the proper voltages, but don't consume any current. What now? 

-I have checked it for compatibility, one user guide said XC3S400 should have XCF02S. But I think it compatible with higher memory, and I saw some article (on forum) where they have used the same configuration.

-Is it possible the two memory is not compatible each other? I think not.

-Maybe some control line on PCB have damaged during the change, so the IC goes to sleep mode? Does it have sleep mode? I didn't saw any sleep mode current in the datasheet. 

Tags (2)
0 Kudos
2 Replies
Scholar austin
Scholar
3,712 Views
Registered: ‎02-27-2008

Re: Change XC3S200 and XCF01S to XC3S400 and XCF04S

Where do you find these are pin compatible?  I was unable to find that.

 

What package do you use?

Austin Lesea
Principal Engineer
Xilinx San Jose
0 Kudos
Visitor 0anubis0
Visitor
1,723 Views
Registered: ‎10-15-2016

Re: Change XC3S200 and XCF01S to XC3S400 and XCF04S

As I seen it was pin compatible.

I have used VO20 package

https://www.xilinx.com/support/documentation/data_sheets/ds123.pdf

 

Probably there was some error in the hardware, anyway thank you for the answer!

0 Kudos