UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor bubujkjk
Visitor
3,419 Views
Registered: ‎08-04-2011

Need help for spartan6 SDI

Hello everyone!~

I am so sorry for my poor english.

I am using xc6slx45t_3csg324 for our HDSDI video, the transmission of which includes both decoding and encoding.

I have decoded SDI video into colorbar successfully, or encode clolor video into HDSDI.

While when they work on the same GTP, for example, using GTPA1_DUAL_X0Y0,output video (throught HDMI) flicks, and the

picture flashes to black sometimes.

This may be caused by decoder lock-lost, but 'locked' signal shows always "1" when I use "chipscope" to observe the signal.
If one of encoder/decoder works itself, decoded video performs stabely.

Any suggestions are appreciated.

Thanks.

0 Kudos
3 Replies
Visitor bubujkjk
Visitor
3,394 Views
Registered: ‎08-04-2011

Re: Need help for spartan6 SDI

none?

0 Kudos
Instructor
Instructor
3,385 Views
Registered: ‎07-21-2009

Re: Need help for spartan6 SDI

I would expect someone like you -- skilled in HDSDI as well as HDMI -- to be knowledgeable about possible causes for the flickering.  What ideas for the flickering have you tested so far, and what were the results of your tests?

 

What have you verified to be working, and what blocks (or combinations of blocks) manifest a problem?

 

I have decoded SDI video into colorbar successfully, or encode clolor video into HDSDI.

 

I don't understand 'decoded SDI video into colorbar' or 'encode color video into HDSDI'.  Can you describe these with more detail, so that your meaning is more clear?

 

This may be caused by decoder lock-lost, but 'locked' signal shows always "1" when I use "chipscope" to observe the signal.

 

What does 'locked' signal mean?  How is it generated?  Is it a clocked (synchronous) signal?  Does chipscope trigger on transitions of 'locked' signal?

 

If one of encoder/decoder works itself, decoded video performs stabely.

 

I do not understand 'if one of encoder/decoder works itself'.  Would you please reword this?

What does 'decoded video performs stabily' mean?  Does this refer to HDMI video output displayed on a monitor?

 

-- Bob Elkind

SIGNATURE:
README for newbies is here: http://forums.xilinx.com/t5/New-Users-Forum/README-first-Help-for-new-users/td-p/219369

Summary:
1. Read the manual or user guide. Have you read the manual? Can you find the manual?
2. Search the forums (and search the web) for similar topics.
3. Do not post the same question on multiple forums.
4. Do not post a new topic or question on someone else's thread, start a new thread!
5. Students: Copying code is not the same as learning to design.
6 "It does not work" is not a question which can be answered. Provide useful details (with webpage, datasheet links, please).
7. You are not charged extra fees for comments in your code.
8. I am not paid for forum posts. If I write a good post, then I have been good for nothing.
0 Kudos
Highlighted
Visitor sumi_u
Visitor
3,318 Views
Registered: ‎05-08-2009

Re: Need help for spartan6 SDI

Hi,

 

I am planning to use Dual stream HD-SDI with triple rate SDI core for Spartan6. I need a confirmation on whether I have to use 2 RX/TX pairs for this or just 1 RX/TX pair. The way I understood is that one 3G-SDI link (carried on RX/TX pair) can support HD-SDI dual stream. Anyone who is familiar with this, please give me a confirmation.

 

Regards,

Sumi

Tags (1)
0 Kudos