UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
3,024 Views
Registered: ‎10-06-2009

Spartan 3 Configuration issue

HI,

 

I have a designed a Spartan 3 XC3S400 configuration based board, but the Spartan 3 IC is not getting detected. I can use the same JTAG circuit to configure another CPLD(while getting Spartan 3 out of the Boundary Scan chain). I have checked the supply and ground pins for the Spartan 3, and they are correct. When I try to initialize the chain through Xilinx ISE 10.1, it cannot detect the device. The device IDCODE read is all zeros. When getting the IDCODE, all the JTAG pins are receiving signals properly, but the FPGA does not respond with proper TDO signal. I have even replaced the Spartan 3 IC, still there is no response.

Please help me with this.

 

 

Regards,

 

Anshuman

0 Kudos
2 Replies
Adventurer
Adventurer
3,013 Views
Registered: ‎03-16-2009

Re: Spartan 3 Configuration issue

Hi

Check FPGA TDI input for shorting to ground. 

 

 

0 Kudos
2,993 Views
Registered: ‎10-06-2009

Re: Spartan 3 Configuration issue

 

Hi Kurgan,

 

I have already checked the TDI pin. It is not shorted to GND, neither are any other JTAG pins. Any other things I should check?

 

 

Regards,

 

Anshuman

0 Kudos