cancel
Showing results for 
Search instead for 
Did you mean: 
Contributor
Contributor
5,245 Views
Registered: ‎12-23-2015

XAPP495 problem

Hey all
I'm working on Digilent Atlys board and I want to implement XAPP495 , but I just want to use one input which I will take it from HDMI out on my laptop and one output which I will connect it to monitor
I will briefly show the steps I done so far


1- Create a new project in ISE. Set the device to XC6SLX45-CSG324, speed grade -3.
2- Add all of the Verilog (.v) files in the XAPP495 distribution to the project.
3- Set dvi_demo.v (2x2 switch matrix) as the top module
4- add dvi_demo.ucf to the project
5- Generate Programming File which had no error.
6- download it to the board after set jumpers which I will talk about them
7-connected HDMI cable from my laptop to the HDMI in on the board
8-connected HDMI cable from the HDMI out on the broad to HDMI in on a screen

 

I know that the dvi_demo may not work if I connect it to a source (such as some PC graphics cards) that require EDID. One solution is to set the jumpers for SCL/SDA pass-through

 

so I
1- Add jumper JP5 to enable HDMI input on J1
2- Installed jumpers JP6/JP7 to enable SDA/SCL pass through from J3.
3-Installed jumpers on the anonymous header labelled SDA/SCL next to J1 (they're called JP2 on the schematic, though). On the boards I've seen and heard about, these were supplied from the factory with jumpers connected, but installed incorrectly, shorting SDA and SCL together on both sides rather than passing them through

 

I done All this and expected my project to work but It keep give me "NO SIGNAL" on the monitor

 

Did I miss anything ? Do I have to do another steps ? Or what ?

 

Thanks.

Tags (1)
0 Kudos