UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Observer teqdruid
Observer
7,243 Views
Registered: ‎03-11-2014

Disable Cross Boundary Optimization

Hi Everyone-

 

I just upgraded from Vivado 2013.4 to 2014.2 and compilation time went from 45 minutes to over six hours! In Vivado 2014.2, a synthesis optimization "Cross Boundary Optimization" takes about 6 hours. Is there any way to disable this optimization? I don't see it specifically referenced anywhere under project settings.

 

~John

0 Kudos
5 Replies
Xilinx Employee
Xilinx Employee
7,231 Views
Registered: ‎09-20-2012

Re: Disable Cross Boundary Optimization

Hi,

In synthesis settings change the "flatten hierarchy" to NONE and see if that helps.

Thanks,
Deepika.
Thanks,
Deepika.
--------------------------------------------------------------------------------------------
Google your question before posting. If someone's post answers your question, mark the post as answer with "Accept as solution". If you see a particularly good and informative post, consider giving it Kudos (the star on the left)
0 Kudos
Xilinx Employee
Xilinx Employee
7,217 Views
Registered: ‎10-24-2013

Re: Disable Cross Boundary Optimization

Hi,
Try using the directive RuntimeOptimized for synthesis
Thanks,Vijay
--------------------------------------------------------------------------------------------
Please mark the post as an answer "Accept as solution" in case it helped resolve your query.
Give kudos in case a post in case it guided to the solution.
0 Kudos
Highlighted
Observer teqdruid
Observer
7,203 Views
Registered: ‎03-11-2014

Re: Disable Cross Boundary Optimization

When I disable hierarchy flattening, the PCIe core I'm using doesn't meet timing.

 

I've ended up using the RuntimeOptimization directive. Which, by the way, is the dumbest possible name for what it is. Is it optimizing the runtime of my hardware or the tools? and "directive"? That doesn't help. Effort_level made sense. This one took me a non-trivial amount of time with google to figure out.

 

Anyway, I was hoping to disable only that optimization. Is there no flag for that? If not, just the lower effort appears to do the trick.

 

~John

0 Kudos
Xilinx Employee
Xilinx Employee
7,194 Views
Registered: ‎07-01-2010

Re: Disable Cross Boundary Optimization

Hi,

I have seen an issue in 2014.2.
Can you try running the below command in the TCL console before launching synthesis run?
set_param synth.elaboration.rodinMoreOptions "set rt::extractNetlistGenomes false

Lets know if this helps.

Regards,
Achutha
---------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------
0 Kudos
Visitor bangzhao
Visitor
4,521 Views
Registered: ‎01-11-2016

Re: Disable Cross Boundary Optimization

I am also stuck in "Start Cross Boundary Optimization";

And your way can not work.

Do you have other solutions? Thank you!

0 Kudos