We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

Showing results for 
Search instead for 
Did you mean: 
Observer sachinb_apt1
Registered: ‎01-03-2018

ERROR: [Synth 8-439] module 'XPM_FIFO_ASYNC' not found for Webpack 2017.4


I have just one file in the project which is basically a wrapper to FIFO in which i infer XPM_FIFO_ASYNC a

Xilinx Parameterized macro.

I synthesis using the below command

synth_design -top my_afifo -part xcku5p-sfvb784-2-e -verilog_define XILINX
and i get the above error.

I expected the macro should be detected by Vivado. But not if the issue is because i am using Webpack.

Can some one from XLNX explain?



Sachin B




0 Kudos
2 Replies
Xilinx Employee
Xilinx Employee
Registered: ‎01-11-2011

Re: ERROR: [Synth 8-439] module 'XPM_FIFO_ASYNC' not found for Webpack 2017.4

Are you perhaps using the non-project flow (no GUI)? In the GUI, it should automatically recognize the XPM macros, however if you are using a script, you need to issue the "auto_detect_xpm" command after you read in your source files.

Please don’t forget to reply, kudo, and accept as solution!
0 Kudos
Xilinx Employee
Xilinx Employee
Registered: ‎08-01-2008

Re: ERROR: [Synth 8-439] module 'XPM_FIFO_ASYNC' not found for Webpack 2017.4

Follow the steps:
1) Open Block design
2) Right Click on Custom IP block {Indicated in error message}
3) Click on Edit in IP packager
4)Go to IP files group --> Is Include ( Unchecked this column)
5)Go to Review and Package --> Re-package IP
6) Then Validate the complete block design and Re-run the synthesis.

Thanks and Regards
Please mark the post as an answer "Accept as solution" in case it helped resolve your query.
Give kudos in case a post in case it guided to the solution.
0 Kudos