UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
12,787 Views
Registered: ‎11-13-2009

ERROR:coreutil - XST has returned an error: ERROR:Xst:2996 - XST patch Expired.

I'm receiving this error when I try and generate a Divider with the Divider Generator 3.0.  I'll post some of my log output, and attach the rest.  I am stumped.  I've updated to the latest 11.4 and everything.

 

Thanks!

- Joseph

 

 

 

ERROR:coreutil:576 - An error occurred while running Java. Please examine the

   console or coregen log file for a specific IP related error.

    For more information please search the Xilinx Answers Database for this

   error: http://www.xilinx.com/support 

ERROR:coreutil - XST has returned an error: ERROR:Xst:2996 - XST patch Expired.

ERROR:coreutil:308 - If the error occurred during generation, the problem may be

   due to a failure occurring in xst.  Please check the xst log file - available

   in the working directory. 

0 Kudos
10 Replies
Contributor
Contributor
12,743 Views
Registered: ‎04-03-2009

Re: ERROR:coreutil - XST has returned an error: ERROR:Xst:2996 - XST patch Expired.

The very same here with DDS Generator 4.0. 11.3 and 11.4 under Vista. :(
0 Kudos
Contributor
Contributor
12,723 Views
Registered: ‎04-03-2009

Re: ERROR:coreutil - XST has returned an error: ERROR:Xst:2996 - XST patch Expired.

I've set the date of my computer back now it generates the core. Strange.
0 Kudos
12,720 Views
Registered: ‎11-13-2009

Re: ERROR:coreutil - XST has returned an error: ERROR:Xst:2996 - XST patch Expired.

Very interesting idea...  I would like to try that but, how far back did you set it?
0 Kudos
Contributor
Contributor
12,717 Views
Registered: ‎04-03-2009

Re: ERROR:coreutil - XST has returned an error: ERROR:Xst:2996 - XST patch Expired.

1st October
0 Kudos
12,709 Views
Registered: ‎11-13-2009

Re: ERROR:coreutil - XST has returned an error: ERROR:Xst:2996 - XST patch Expired.

Great!  Setting my date back to October 1, 2009 resolves this issue.  Until Xilinx issues an update addressing this issue, setting your clock back to that date will allow for CoreGEN to properly generate the cores.
0 Kudos
Visitor endi
Visitor
12,659 Views
Registered: ‎11-11-2009

Re: ERROR:coreutil - XST has returned an error: ERROR:Xst:2996 - XST patch Expired.

I'm getting these errors from ISE/Core Generator 11.3 also.  I'm trying to modify an old core, and upgrade it at the same time.  First I observed ERROR:sim - Upgrade Aborted.  So I did what I always do, manually capture all the significant parameters and options, start a new core, and configure it to be the same in every way possible to the old one, except for the changes I want.  This gives me ERROR:coreutil - An error occurred while running Java.  Also, ERROR:Xst:2996 - XST patch Expired.

 

I'll try to roll the clock back 20 years so I can keep track of date and time for version control.  October won't work, since some of my files were actually generated then.

0 Kudos
Xilinx Employee
Xilinx Employee
12,646 Views
Registered: ‎11-28-2007

Re: ERROR:coreutil - XST has returned an error: ERROR:Xst:2996 - XST patch Expired.

This has been addressed in http://www.xilinx.com/support/answers/33993.htm

 

Cheers,

Jim

 

Cheers,
Jim
Highlighted
Visitor endi
Visitor
12,625 Views
Registered: ‎11-11-2009

Re: ERROR:coreutil - XST has returned an error: ERROR:Xst:2996 - XST patch Expired.

This worked for me on 11.3.

 

I thought I'd download the 11.4 upgrade at the same time, but that's taking a long time for my web browsing PC to get, and will clearly threaten the limits of my memory stick.

 

When I use "ERROR:Xst:2996" or "2996" in the Xilinx web page search engine box for the Answer Browser, I get:

Your search - ERROR:Xst:2996 - did not match any documents.
No pages were found containing "ERROR:Xst:2996".

When I use "ERROR:Xst:2996" in the Xilinx web page search engine box for Forum Message Search, I get:

Sorry, your search yielded no matching results.

Please revise your search query

 

This would explain why we cannot find answer record 33993.  Any idea why words in the title and the keyword list don't get a hit from the search engine?  Perhaps this topic is too new.

0 Kudos
Xilinx Employee
Xilinx Employee
12,611 Views
Registered: ‎11-28-2007

Re: ERROR:coreutil - XST has returned an error: ERROR:Xst:2996 - XST patch Expired.

Yes, AR33993 was too new yesterday. Anyway, it's searchable now.

 

 

 

Cheers,
Jim
0 Kudos
Explorer
Explorer
3,595 Views
Registered: ‎07-08-2008

Re: ERROR:coreutil - XST has returned an error: ERROR:Xst:2996 - XST patch Expired.

Thx for the #AR33993

 

It worked for me under 11.3.

 

 

Greetings, Mariusz.

 

--
Mariusz Grad.
0 Kudos