cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Visitor
Visitor
11,635 Views
Registered: ‎04-17-2012

Hierarchy enabling ?

Jump to solution

Hi,

I'm using Vivado 2014.3 and I have this warning when synthesizing my project:

 

[Netlist 29-101] Netlist 'aes128_fast' is not ideal for floorplanning, since the cellview 'aes128_fast' contains a large number of primitives. Please consider enabling hierarchy in synthesis if you want to do floorplanning.

 

What does it mean exactly? And how do I enable hierarchy in synthesis? I don't find any such  setting.

Thx.

0 Kudos
Reply
1 Solution

Accepted Solutions
Xilinx Employee
Xilinx Employee
19,756 Views
Registered: ‎10-24-2013

Hi,

Thanks,Vijay
--------------------------------------------------------------------------------------------
Please mark the post as an answer "Accept as solution" in case it helped resolve your query.
Give kudos in case a post in case it guided to the solution.

View solution in original post

Capture.JPG
0 Kudos
Reply
11 Replies
Xilinx Employee
Xilinx Employee
11,630 Views
Registered: ‎09-20-2012

Hi,

 

Set the flatten_hierarchy to none in synthesis settings to preserve the hierarchy.

 

Thanks,

Deepika.

Thanks,
Deepika.
--------------------------------------------------------------------------------------------
Google your question before posting. If someone's post answers your question, mark the post as answer with "Accept as solution". If you see a particularly good and informative post, consider giving it Kudos (the star on the left)
0 Kudos
Reply
Xilinx Employee
Xilinx Employee
19,757 Views
Registered: ‎10-24-2013

Hi,

Thanks,Vijay
--------------------------------------------------------------------------------------------
Please mark the post as an answer "Accept as solution" in case it helped resolve your query.
Give kudos in case a post in case it guided to the solution.

View solution in original post

Capture.JPG
0 Kudos
Reply
Moderator
Moderator
11,615 Views
Registered: ‎07-21-2014

Hi,

 

Refer below AR for information on -flatten_hierarchy switch:

http://www.xilinx.com/support/answers/52257.html

 

Thanks,
Anusheel
-----------------------------------------------------------------------------------------------
Search for documents/answer records related to your device and tool before posting query on forums.
Search related forums and make sure your query is not repeated.

Please mark the post as an answer "Accept as solution" in case it helps to resolve your query.
Helpful answer -> Give Kudos
-----------------------------------------------------------------------------------------------

0 Kudos
Reply
Xilinx Employee
Xilinx Employee
11,585 Views
Registered: ‎09-20-2012

Hi @binomex

 

Did that help?

 

Thanks,

Deepika.

Thanks,
Deepika.
--------------------------------------------------------------------------------------------
Google your question before posting. If someone's post answers your question, mark the post as answer with "Accept as solution". If you see a particularly good and informative post, consider giving it Kudos (the star on the left)
0 Kudos
Reply
Visitor
Visitor
11,581 Views
Registered: ‎04-17-2012

Yes that helped. Sorry I've forgotten to mention that.

Thank you all.

0 Kudos
Reply
Participant
Participant
9,326 Views
Registered: ‎05-14-2015

HI,

 

In my design even if i keep the flatten heirarchy as none, i get the same warnning. 

 

Kindly let me know what to do . 

0 Kudos
Reply
Adventurer
Adventurer
1,456 Views
Registered: ‎05-31-2019

In my design also even if I set the flatten heirarchy as none, i get the same warnning.

Pleaese assist to what to do to resolve this warning.

0 Kudos
Reply
Moderator
Moderator
1,427 Views
Registered: ‎03-16-2017

Hi @knugent ,

You are replying to an old post. 

Kindly create a new thread with your detailed query so community can help you better.

Regards,
hemangd

Don't forget to give kudos and mark it as accepted solution if your issue gets resolved.
0 Kudos
Reply
Adventurer
Adventurer
1,413 Views
Registered: ‎05-31-2019

Sorry but this relates to same problem ssankar1 reported and no one commented on this matter. 

0 Kudos
Reply
Moderator
Moderator
1,404 Views
Registered: ‎03-16-2017

Hi @knugent ,

This thread is already closed and marked as accepted solution. 

Even if your issue is same you have to create a new thread so community can help you better. 

Regards,
hemangd

Don't forget to give kudos and mark it as accepted solution if your issue gets resolved.
0 Kudos
Reply
Newbie
Newbie
467 Views
Registered: ‎10-16-2020

Hi , 

I am also facing the same problem. Even after setting flatten hierarchy to "NONE". I ma getting same error which is " Design is not ideal for floor planning, since xxx contains a large number of primitives. Please consider enabling hierarchy in synthesis if you want to do floor planning".

Please suggest...

 

0 Kudos
Reply