cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
chughsumit
Participant
Participant
5,735 Views
Registered: ‎03-04-2015

ILA probes optimized

Hi,

 

I inserted ILA probes after synthesis in netlist and able to implement anf generate bitfile.

In next synthesis run, i do had some design changes and some nets were optimized and tool reported error during opt_design that ILA probes not found . So I need to remove all the unconnected probes from the ILA debug port probes in GUI mode after opening synthesized design netlist and re-run implement- opt_design.

 

Is there a command or property that make sure it removes all unconnected probes and continue opt_design..? So that the tool dont report error for these ILA probes nets not found/unconnected.

Please help share.

 

thanks,

Sumit

0 Kudos
1 Reply
vemulad
Xilinx Employee
Xilinx Employee
5,730 Views
Registered: ‎09-20-2012

Hi,

 

There is no tool switch/option to allow unconnected channels of ILA core.

 

Check this related thread http://forums.xilinx.com/t5/Implementation/Is-it-possible-to-build-with-unconnected-debug-channels/td-p/536795

 

Thanks,

Deepika.

Thanks,
Deepika.
--------------------------------------------------------------------------------------------
Google your question before posting. If someone's post answers your question, mark the post as answer with "Accept as solution". If you see a particularly good and informative post, consider giving it Kudos (the star on the left)
0 Kudos