UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Adventurer
Adventurer
721 Views
Registered: ‎01-26-2017

Large dual-port BRAM reads (Native) does not read every cycle

Jump to solution

Hi there,

 

I am having some trouble using BRAMs as 5 row buffers stuck together. I have dual port BRAM that is writing 14 bit data in on the A port, and reading out 448 bit data on the B port, which is constructed into a 5x5 kernel for later use. The issue I am having is that my reads should occur every cycle as the kernel "slides across" the row buffers, but the problem is that the output data changes only every 8 cycles. 

 

I have attached some screenshots to explain my design. Checking the screenshot, it is clear that my reading and writing should be done by incrementing by the size of my kernel (which is 5 in this case). I.e on first cycle, read_addr = 0, then on 2nd, read_addr = 5 etc.  

 

And then the waveform output does not change every cycle, however notice that the output is a zero matrix at address 40 as expected. This is very confusing to me, my wr_en and rd_en are constant on their respective ports, otherwise I would say this is just that my rd_en is being held low for 8 cycles etc or my din on the write port is held constant by accident. Does anyone have any ideas?

 

Thanks for your time.

--- Estimated Development time: 2*Pi*(planned completion date) ---
Tags (3)
memory structure.PNG
bram_reads.PNG
0 Kudos
1 Solution

Accepted Solutions
Xilinx Employee
Xilinx Employee
942 Views
Registered: ‎05-14-2008

Re: Large dual-port BRAM reads (Native) does not read every cycle

Jump to solution

Since you've had a new post on that board, please close this thread by accepting an answer as solution. Thanks.

 

-vivian

0 Kudos
3 Replies
Xilinx Employee
Xilinx Employee
690 Views
Registered: ‎05-14-2008

Re: Large dual-port BRAM reads (Native) does not read every cycle

Jump to solution

The BRAM/FIFO board is more appropriate for your problem.

https://forums.xilinx.com/t5/BRAM-FIFO/bd-p/OTHERIP

 

-vivian

Adventurer
Adventurer
683 Views
Registered: ‎01-26-2017

Re: Large dual-port BRAM reads (Native) does not read every cycle

Jump to solution

Thanks, will report there

--- Estimated Development time: 2*Pi*(planned completion date) ---
0 Kudos
Xilinx Employee
Xilinx Employee
943 Views
Registered: ‎05-14-2008

Re: Large dual-port BRAM reads (Native) does not read every cycle

Jump to solution

Since you've had a new post on that board, please close this thread by accepting an answer as solution. Thanks.

 

-vivian

0 Kudos