cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Observer
Observer
4,648 Views
Registered: ‎07-30-2010

Problem including *.h file in Xilinx ISE

Jump to solution

Hi all,

I have a quite complex design whereas one module has the following include definition at the beginning:

////////////////////////////////////////////////////////////////////////
// Global header file includes
////////////////////////////////////////////////////////////////////////
`include        "sys.h" // system level definition file which contains the
                                        // time scale definition

I have added the sys.h file to the project by right click on the project and then "add source" --->
browse to directory where sys.h is located. Adding it a second time fails, because it has already

been added to the design!

When I run sythesis with Xilinx XST 10.1.03 I get the following error:
ERROR:HDLCompilers:26 - "../design/sys/iop/sparc/tlu/rtl/tlu_rrobin_picker.v" line 30 Could not find verilog include file 'sys.h'
Analysis of file <"sparc.prj"> failed.

Anyone an idea why XST ISE fails to find sys.h?

Many thanks,
Richard.

0 Kudos
Reply
1 Solution

Accepted Solutions
Professor
Professor
5,762 Views
Registered: ‎08-14-2007

ISE does not use the project files to find the `include files for Verilog.  So in essence adding

sys.h to the project only gives you a convenient way to open it for editing.  For include files that

are not in the project directory you need to add the path to the Verilog Include Directories

under the Synthesis Properties settings.  If you use a command line flow the switch you

need is -vlgincdir

 

The Synthesis Properties dialog box allows you to browse to the directory to select it.

 

HTH,

Gabor

-- Gabor

View solution in original post

0 Kudos
Reply
3 Replies
Professor
Professor
5,763 Views
Registered: ‎08-14-2007

ISE does not use the project files to find the `include files for Verilog.  So in essence adding

sys.h to the project only gives you a convenient way to open it for editing.  For include files that

are not in the project directory you need to add the path to the Verilog Include Directories

under the Synthesis Properties settings.  If you use a command line flow the switch you

need is -vlgincdir

 

The Synthesis Properties dialog box allows you to browse to the directory to select it.

 

HTH,

Gabor

-- Gabor

View solution in original post

0 Kudos
Reply
Observer
Observer
4,640 Views
Registered: ‎07-30-2010

Brilliant Gabor, that did the trick ;)

0 Kudos
Reply
Visitor
Visitor
4,589 Views
Registered: ‎07-14-2011

ca you help me to intrgrate a .h file

Tags (1)
0 Kudos
Reply