cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Visitor
Visitor
412 Views
Registered: ‎06-09-2020

Vivado 2020.1 TCL The object 'run' does not have a property 'STEPS.SYNTH_DESIGN.ARGS.FANOUT_LIMIT'.

Jump to solution

Hello, 

I have one piece of TCL code working for Vivado 2018.3, i am trying to move to Vivado 2020.1 but i cant set the fanout limit as before using Vivado synthesis 2020.

 

create_run synth_1 -flow {Vivado Synthesis 2020}

set_property STEPS.SYNTH_DESIGN.ARGS.FANOUT_LIMIT 100 [get_runs synth_1]

When using the last instruction : 

ERROR: [Common 17-54] The object 'run' does not have a property 'STEPS.SYNTH_DESIGN.ARGS.FANOUT_LIMIT'.

 

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Xilinx Employee
Xilinx Employee
282 Views
Registered: ‎06-14-2018

Hi @ellorens ,

There are multiple options not all are listed below:

opt_design -hier_fanout_limit

physopt_design -fanout_opt (default)

Along with this their are various directives you can choose , please refer UG904 : Vivado Design Suite User Guide: Implementation 

Thanks,

Ajay

View solution in original post

0 Kudos
3 Replies
Highlighted
Xilinx Employee
Xilinx Employee
328 Views
Registered: ‎06-14-2018

Hi @ellorens ,

Synth_design option "fanout_limit" is deprecated. You can use options in placer, physical synthesis for fanout handling.

 

Thanks,

Ajay

0 Kudos
Highlighted
Visitor
Visitor
314 Views
Registered: ‎06-09-2020

Could you please provide an example? It would be very helpful to have a proper update of that tcl code so we can close the topic.

 

Thank you in advance

0 Kudos
Highlighted
Xilinx Employee
Xilinx Employee
283 Views
Registered: ‎06-14-2018

Hi @ellorens ,

There are multiple options not all are listed below:

opt_design -hier_fanout_limit

physopt_design -fanout_opt (default)

Along with this their are various directives you can choose , please refer UG904 : Vivado Design Suite User Guide: Implementation 

Thanks,

Ajay

View solution in original post

0 Kudos