cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Explorer
Explorer
9,277 Views
Registered: ‎01-12-2009

Vivado synthesis console output suppress

Other than redirecting to a NUL device, is there an easy way to tell Vivado to only log to the journal file, but not write to the console?

 

With even fairly small builds the synthesis output to the console seems to be using a lot of time.

 

This is for non-project mode run from a command shell. The -mode switch is set to batch.

 

Win7 x64, Vivado 2015.1.


Ian Lewis

www.mstarlabs.com

0 Kudos
4 Replies
Highlighted
Teacher
Teacher
9,197 Views
Registered: ‎03-31-2012

I am pretty sure I always use -mode tcl -source run.tcl and no console output is produced.
- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.
0 Kudos
Highlighted
Explorer
Explorer
9,170 Views
Registered: ‎01-12-2009

Thank you for the reply, . But, the -mode tcl seems to only differ from -mode batch in that it does not exit Vivado after it completes script execution (UG835 (v2015.1), p.4). It still logs lots of output to the console.

 

Ian

 

 

0 Kudos
Highlighted
Teacher
Teacher
9,147 Views
Registered: ‎03-31-2012

try -notrace to vivado & see how much output you get.
- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.
0 Kudos
Highlighted
Explorer
Explorer
9,116 Views
Registered: ‎01-12-2009

I tried -notrace after the -source <file> command to Vivado. I could not find any documentation on a -notrace switch to Vivado itself.

 

This did seem to source the file with the -notrace option to source.

 

That reduced the output slightly, but the main culprit for massive output is synthesis and implementation information. And that still comes out both in the log file as well as to the screen.

 

I did, based on what I found while looking for the -notrace option you suggested, find a backwards workaround, though I do not love it: I use -nolog and -nojournal and then redirect the console output into a log file.

 

This is backwards I turn off the log, and keep the console output, but at least Vivado is not writing to two places.

 

I still would like a simple way to tell Vivado to just show serious errors to the console and only write the bulk output to the log and journal.


Ian

0 Kudos