UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Adventurer
Adventurer
90 Views
Registered: ‎04-07-2014

pack DSP OPMODE

Hi all,

I am using Vivado 2018.3 and stumbling on the following info:

INFO: [Synth 8-5842] Cannot pack DSP OPMODE registers because of constant '1' value. Packing the registers will cause simulation mismatch at initial cycle.

Vivado synthesis detects my dsp operations correctly, however timing is not met because OPMODE register is not used. During initial cycle there is no operation and simulation mismatch is irrelevant.

My question: Vivado detects the situation correctly. Is there an option to tell Vivado Synthesis to ignore simulation mismatch and pack OPMODE register into DSP anyway?

Thanks and regards,

Sebastian

0 Kudos
2 Replies
Moderator
Moderator
27 Views
Registered: ‎07-21-2014

Re: pack DSP OPMODE

@sgeorgi_sen

Which device you are targetting to? Also, did you try use_dsp attribute, I doubt this will help but please give a try.

Can you show us your code here?

Thanks
Anusheel

0 Kudos
Adventurer
Adventurer
12 Views
Registered: ‎04-07-2014

Re: pack DSP OPMODE

@anusheel

Hi anusheel,

thanks for your reply. I am using Artix 7 and Vivado 2018.3. Please find attached an example file and synthesis report. DSP functions (such as Z-Mux and AddSub) are detected correctly. Only the OPMODE register is placed outside in a separate FF for simulation accuracy reasons.

As you already assumed, the usp_dsp attribute does not help - this was my first thought as well.

Help is appreciated.

Thanks and regards,

Sebastian

0 Kudos