UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Newbie hofith
Newbie
53 Views
Registered: ‎02-07-2019

High Speed SelectIO IP - TX serial data different from TX IP input

We're trying to use the High Speed SelectIO IP's example design to send serial data in a rate lower than 100Mbps

For this we use the TX with the 8bit input in 125MHz, for 1000Mbps data rate and send every bit 16 times.

 

The problem is, the serial interface only sends 0 or F.

For instance, if B is inserted, meaning 1*16,0*16,1*16,0*16,

On the serial line we see 1 for 64ns - meaning 4 bits of 1, indicating F

 

We'd appreciate your help with solving the issue.

Thanks,

Hofit

highspeed selective IO issue.JPG
0 Kudos
1 Reply
Community Manager
Community Manager
26 Views
Registered: ‎08-08-2007

Re: High Speed SelectIO IP - TX serial data different from TX IP input

Hi @hofith

 

I'm struggling a little to understand the setup. 

My understanding is that the core_data_from_fabric_xx input of your HSSIO is "00" "00" "FF" "FF" repeating, giving a serial stream of 16 0's, then 16 1's.

In the screenshot the signal names are missing, I'm assuming the first signal is the serial clock, is the second the data to the TX_BITSLICE? Its wider than 8 bits and doesn't match the description of  0000FFFF.

I did a quick simulation with the example design and just changed the test data to 00 FF and the simulation output is as expected. 

If you could explain further the screen shot I can try to make my simulation match yours.

Sandy

 

-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos