UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor suramyag1
Visitor
170 Views
Registered: ‎09-18-2018

ZCU102: Ubuntu Core`

Jump to solution

I wanted to run Ubuntu Core on ZCU102. I've followed the following documentations:

https://xilinx-wiki.atlassian.net/wiki/spaces/A/pages/18841937

https://xilinx-wiki.atlassian.net/wiki/spaces/A/pages/18842112

However, both of them need PCIe disabled, which is required. I then found https://www.xilinx.com/support/answers/66636.html which seemed helpful. 

The link to Ubuntu 14.04: http://cdimage.ubuntu.com/ubuntu-core/releases/14.04/release/ubuntu-core-14.04.3-core-arm64.tar.gz has become invalid. I tried with Ubuntu 16.04 (http://cdimage.ubuntu.com/ubuntu-base/releases/16.04/release/), but on using the chroot command: 

chroot /chroot_mnt

it throws the following error:

chroot: can't execute '/bin/sh': Exec format error

On searching for the error, it seems that this occurs when a 32 bit system is run on a 64 bit system. However, both the petalinux (created for ZCU102) and Ubuntu Core (I'm using the amd64 core, as that's what was described in AR #66636) are 64-bit. 

What could be the problem? 

 

Thanks in advance. 

0 Kudos
1 Solution

Accepted Solutions
Explorer
Explorer
131 Views
Registered: ‎03-31-2016

Re: ZCU102: Ubuntu Core`

Jump to solution

The ZCU102 uses an ARM 64-bit processor not an AMD 64-bit processor. 

You must use the arm64 core not amd64 core

0 Kudos
2 Replies
Visitor suramyag1
Visitor
162 Views
Registered: ‎09-18-2018

Re: ZCU102: Ubuntu Core`

Jump to solution

I found the 14.04 version here:

http://cdimage.ubuntu.com/ubuntu-base/releases/14.04/release/

It gives the same error as the 16.04 version. 

0 Kudos
Explorer
Explorer
132 Views
Registered: ‎03-31-2016

Re: ZCU102: Ubuntu Core`

Jump to solution

The ZCU102 uses an ARM 64-bit processor not an AMD 64-bit processor. 

You must use the arm64 core not amd64 core

0 Kudos