取消
显示结果 
搜索替代 
您的意思是: 
Highlighted
Observer
Observer
1,624 次查看
注册日期: ‎07-10-2018

XCZU19EG Bit无法加载问题

我这边一款自己设计的XCZU19EG的板子,在JTAG模式下下载bit能够正常运行。

但是在QSPI32模式和eMMC18模式下面把bin文件烧写进去重启之后均无法正常加载程序。

有几个现象:

1、在JTAG模式下面,板子会报 [Labtools 27-3421] xczu19_0 PL Power Status OFF, cannot connect PL TAP.  Check POR_B signal.的错误,SYSMON下PL和PS端的温度均能被监测到,但比较奇怪的现象是VCC_PSINTFP在PL端能够被监测到,但是在PS端则显示监测值为0V,且VCCO_PSDDR监测值也为0V. 用示波器测量过这两路电源的电压均是正常的。

2、在QSPI32和eMMC18模式下面,板子上电同样会报 [Labtools 27-3421] xczu19_0 PL Power Status OFF, cannot connect PL TAP.  Check POR_B signal.的错误,但是此时在SYSMON下面,PL端的温度和电压均无法被监测到,只有PS端的温度能够被监测到,同时VCC_PSINTFPVCCO_PSDDR的监测值均为0V。

3、在JTAG模式下面,ZU19EG的INIT_B状态正常,下载BIT之后,CONFIG_DOWN信号正常。在QSPI32和eMMC模式下,INIT_B状态不正常,同时FPS_ERROR_OUT信号为高。这个应该是QSPI32模式和eMMC模式下,ZU19EG在QSPI和eMMC里面读不出正常的东西,所以报错。

主要是第1点和第2点问题,是否有人遇到过类似的问题,还请协助解答一下疑问,谢谢。

0 项奖励
5 条回复5
Highlighted
Xilinx Employee
Xilinx Employee
1,508 次查看
注册日期: ‎04-15-2011

回复: XCZU19EG Bit无法加载问题

从你的描述看,感觉是你的上电时序有问题,如果上电之后,按一下POR_B,还会出现这个现象吗?另外,你的SYSMON的供电是否正常?
另外,在QSPI32和eMMC模式下,如果启动后什么打印也没有,可以通过连接JTAG,读一下这个寄存器0xFFD80528,看看对应的error code是多少,看看CSU有没有报错误信息。通常启动的最开始,CSU(bootrom)运行期间,PMU会检测power的,如果power检测有问题,后续过程会有问题的。
-------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 项奖励
Highlighted
Observer
Observer
1,373 次查看
注册日期: ‎07-10-2018

回复: XCZU19EG Bit无法加载问题

你好,
目前我的上电时序是
Sequence1 VCCINT + VCCINTIO + VCCBRAM + VCC_PSINTLP + VCC_PSINTFP + VCC_INTFP_DDR 合并供电。
Sequence2 VCCAUX + VCCADC + VCCAUX IO + VCC_PSAUX + VCC_PSADC + VCC_PSDDR_PLL (加滤波) 合并供电。
Sequence3 FPS_VCC_PLL
Sequence4 FPL_MGT_AVCC
Sequence5 FPL_MGT_AVTT
Sequence6 FPL_VCC_1V35(PL VCCO For DDR3L)
Sequence7 FPL_MGT_AUX
Sequence8 FPS_VCC_1V8 + FPL_VCC_1V8(PL / PS VCCO)
Sequence9 FPS_VCC_1V35(PS VCCO For DDR3L)
Sequence10 VCC_3V3(VCCO)
所有的上电均是前一级电源芯片的PowerGood去使能下一级电源芯片的PowerEN。
目前是内核能够启动了,但是SYSMON的检测还是有问题,SYSMON的供电是通过FPS_VCC_1V8通过磁珠接过去的,供电是正常的。
0 项奖励
Highlighted
Observer
Observer
1,368 次查看
注册日期: ‎07-10-2018

回复: XCZU19EG Bit无法加载问题

你好,

        PL端和PS端的SYSMON截图如下,VCC_PSINTFP在SYSMON的PL端能够正常读到,但是在SYSMON的PS端却无法读到。

        有一个现象是复位POR_B信号并不是在电源启动过程中一直保持为低电平,复位电路的截图如附件。在FPS_VCC_1V8起来的时候,POR_B会产生一个短暂的高脉冲,然后再变低,等最后VCC_3V3启动之后,延迟150ms之后变高。

        

PL.png
PS.png
复位.png
微信图片_20190219154725.jpg
0 项奖励
Highlighted
Visitor
Visitor
963 次查看
注册日期: ‎04-09-2019

回复: XCZU19EG Bit无法加载问题

我也遇到了和你一模一样的问题,请教一下请问你的问题解决了吗?
0 项奖励
Highlighted
Visitor
Visitor
340 次查看
注册日期: ‎03-27-2020

回复: XCZU19EG Bit无法加载问题

我画的zu15也遇到了您同样的问题,扫不到arm,说是PS_POR_B为低,但是我硬件测试是高电平

标记 (1)
0 项奖励