UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Contributor
Contributor
450 Views
Registered: ‎05-31-2019

Booting from a SD card in ZCU104

Jump to solution

Hi,

Can someone properly explain how to boot from a SD card in Xilinx ZCU104? I followed the documentation (https://www.xilinx.com/support/documentation/boards_and_kits/zcu104/ug1267-zcu104-eval-bd.pdf) and set the switches(1110) as below:

IMG_20191003_162417.jpgDIP switches

 

IMG_20191003_162413.jpgSW6

I am not sure if this is the correct way to set them to boot. The led beside the switches is always red. Regardless I tried to see any messages coming up while booting from a serial console. In my case I'm using gtkterm. I opened several windows for all the tty with a baud rate of 115200. But nothing shows up in the serial console as well. I have formatted the SD card as FAT32 and copied the BOOT.bin and the image.ub file from my petalinux project to the sd card.

I am confused as to why this is happening and if I'm doing something wrong. If someone can help with this situation it'll be really great. Thank you.

Tags (3)
0 Kudos
1 Solution

Accepted Solutions
Observer kiran1490
Observer
364 Views
Registered: ‎08-09-2019

Re: Booting from a SD card in ZCU104

Jump to solution

The configuration for SD BOOT for ZCU104 is wrong in your case .  Switch SW6 configuration switch 1 should be in ON condition and Switch 4 Should be in OFF condition. Basically you have interchange the positions of switch 1 and switch 4 as shown in below diagram.

View solution in original post

1.jpeg
3 Replies
Observer kiran1490
Observer
365 Views
Registered: ‎08-09-2019

Re: Booting from a SD card in ZCU104

Jump to solution

The configuration for SD BOOT for ZCU104 is wrong in your case .  Switch SW6 configuration switch 1 should be in ON condition and Switch 4 Should be in OFF condition. Basically you have interchange the positions of switch 1 and switch 4 as shown in below diagram.

View solution in original post

1.jpeg
Highlighted
Contributor
Contributor
346 Views
Registered: ‎05-31-2019

Re: Booting from a SD card in ZCU104

Jump to solution

@kiran1490 I tried your configuration but I get the same results. Red LED and nothing in the serial console. I have connected the FPGA to the pc (via UART) and to a power supply. Should my PC have some mandatory requirements that needs to be met before I can see anything in the console for ZCU104? Also what should be the correct configuration for the DIP switches?

0 Kudos
Observer kiran1490
Observer
309 Views
Registered: ‎08-09-2019

Re: Booting from a SD card in ZCU104

Jump to solution

There is no need to configure SW17 DIP switches for the mode of booting. Only you have to configure SW6 switches . Take a glance at ZCU104 Userguide for SW6 and SW17 switches and configure only SW6 switches according to my previous reply. If you are using windows try teratorm serial console and if you are using linux try gtkterm and set the USB0 and Baudrate 115200 as confiurations in serial console.

0 Kudos