UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Adventurer
Adventurer
715 Views
Registered: ‎12-03-2013

LVDS signals query

Jump to solution

Hi All,

 

I have multiple LVDS signal pairs(Tx and Rx) in my design on an Ultrascale + FPGA.

I plan to test performance at 400Mbps using an external loopback . My test setup is giving a fixed pattern output on Tx and then looping in back and checking on Rx. I see that for few signal pairs the received pattern is not same as the transmitted pattern.

 

I am currently using OBUFDS/IBUFDS in my design. I would like to know if this is enough or we need to use any other primitive.

 

Can anyone please help me out with this.

 

Regards

Ayusman

0 Kudos
1 Solution

Accepted Solutions
Adventurer
Adventurer
769 Views
Registered: ‎12-03-2013

Re: LVDS signals query

Jump to solution

Hi,

 

Thanks for the replies.

After debugging found out it was related to hardware issue. Got it fixed and now it is working fine.

 

Regards

Ayusman

View solution in original post

0 Kudos
3 Replies
Adventurer
Adventurer
707 Views
Registered: ‎05-23-2018

Re: LVDS signals query

Jump to solution

What is the relation between your Clock and Data? How have you defined that?

 

Are you using source or system synchronous transmission? Do you output the clock through a ODDR or OSERDES or directly? Are you using an IDDR or ISERDES for the input side?

 

Compare xapp585 for a standard use-case using LVDS for video data.

0 Kudos
Scholar drjohnsmith
Scholar
697 Views
Registered: ‎07-09-2009

Re: LVDS signals query

Jump to solution

Could be signal errors or could be timing

 

Try slowing the data down to say 10 Mhz, 

  does that work, if so , its likely to be bad termination .

 

If not, its likely to be timing.

 

<== If this was helpful, please feel free to give Kudos, and close if it answers your question ==>
Adventurer
Adventurer
770 Views
Registered: ‎12-03-2013

Re: LVDS signals query

Jump to solution

Hi,

 

Thanks for the replies.

After debugging found out it was related to hardware issue. Got it fixed and now it is working fine.

 

Regards

Ayusman

View solution in original post

0 Kudos