UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Explorer
Explorer
966 Views
Registered: ‎02-17-2009

Problem enabling DIFF_TERM on LVDS inputs

I am trying to enable 100 Ohm terminations on LVDS inputs in an Ultrascale Kintex device but it doesn't seem to work. I am using the following constraints as described in AR# 67219:

 

set_property DIFF_TERM_ADV TERM_100 [get_ports Clk_Dco1_P]
set_property DIFF_TERM_ADV TERM_100 [get_ports Clk_Dco1_N]

etc..

 

but they seem to be ignored.  Any help would be appreciated.

 

 

 

 

 

0 Kudos
6 Replies
Scholar drjohnsmith
Scholar
960 Views
Registered: ‎07-09-2009

Re: Problem enabling DIFF_TERM on LVDS inputs

How are you defining the LVDS port in the code,

   whats your language ?

 

In VHDL I'd be instantiating the LVDS at the top level, 

   

<== If this was helpful, please feel free to give Kudos, and close if it answers your question ==>
0 Kudos
926 Views
Registered: ‎06-21-2017

Re: Problem enabling DIFF_TERM on LVDS inputs

Are these HP or HR banks and what is the VCCO? 

0 Kudos
Explorer
Explorer
861 Views
Registered: ‎02-17-2009

Re: Problem enabling DIFF_TERM on LVDS inputs


@drjohnsmith wrote:

How are you defining the LVDS port in the code,

   whats your language ?

 

In VHDL I'd be instantiating the LVDS at the top level, 

   


Yes, they are defined through instantiations in the top level VHDL.

 

 

0 Kudos
Explorer
Explorer
860 Views
Registered: ‎02-17-2009

Re: Problem enabling DIFF_TERM on LVDS inputs


@bruce_karaffa wrote:

Are these HP or HR banks and what is the VCCO? 


I have them in both HP and HR banks. The VCCO is 2.5V for the HR banks and 1.8V for the HP.

0 Kudos
Moderator
Moderator
832 Views
Registered: ‎09-18-2014

Re: Problem enabling DIFF_TERM on LVDS inputs

mmatsusov,

 

How are they ignored? Is there a warning or error message from Vivado stating as such? Does the DIFF_TERM checkbox in the IO pin planner show it as not selected for the IO ports? Are you using a single differential buffer for the input pair? 

 

Regards,

T

 

 

-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
Explorer
Explorer
828 Views
Registered: ‎02-17-2009

Re: Problem enabling DIFF_TERM on LVDS inputs


@tenzinc wrote:

mmatsusov,

 

How are they ignored? Is there a warning or error message from Vivado stating as such? Does the DIFF_TERM checkbox in the IO pin planner show it as not selected for the IO ports? Are you using a single differential buffer for the input pair? 

 

Regards,

T

 

 


There were no warning or error messages but actually they are not ignored anymore. The worst part is that I am not sure what I did.. 

0 Kudos