cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Visitor
Visitor
315 Views
Registered: ‎06-12-2020

ZCU 216 MTS operation problem (Spur)

 Hi all,

I am a new beginner for XILINX products. Our lab recently purchases a ZCU 216 ES1 Evaluation Kit for our chip testing. We are intended to generate 16 input signal (Differential+ IQ using 8 DACs) under MTS mode.

I have already assembled the board and run the example (Non-MTS) that provided on the website and it works for me by observing the same results.

https://xilinx-wiki.atlassian.net/wiki/spaces/A/pages/246153525/RF+DC+Evaluation+Tool+for+ZCU216+board+-+Quick+start

I am now trying to generate the signal under MTS mode, however, facing some difficulties:

Here are the settings and procedure that I proceed:

1. Enabling the MTS mode at both ADCs / DACs using the GUI interface

2. Generate the Signal (single tone, no IQ) using Multiview DAC 

3. Observe the signal either through the balun (10MHz~1GHz), or directly connect to spectrum.

Unfortunately, I did not get the results but observing lots of unwanted spurious tone.

Attached picture is the output while I observe different carrier frequency (150MHz, 250MHz) on DAC01. I also try CF=500MHz and the spur problem is the same as in 150 MHz.

I try to mimic the procedure on ZCU111 which we also have one in lab currently and it works. However, this does not apply to 216 board. 

In ZCU111, there will be a place to bypass the PLLs and apply specific frequency for MTS operations, but it seems like there is not such an option in 216 board.

I was wondering if anyone has a experience on it or have any tutorial/guide on ZCU 216 MTS operations.

Please kindly advice!

Thanks in advance.

 

Clock distribution settings.png
DAC MTS setting.png
On board PLL settings.png
DAC_150e6.png
250e6.png
150e6.png
0 Kudos
4 Replies
Highlighted
Moderator
Moderator
209 Views
Registered: ‎04-18-2011

Hi @cclinrichard 

I don't expect that MTS can cause these spurs. 

What is it like if you just look at the output of one of these DAC tiles independently?

What is the tile set up of the like in this case? 

Keith 

-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
Highlighted
Visitor
Visitor
181 Views
Registered: ‎06-12-2020

Hi @klumsde ,

Thanks for your reply. The MTS mode is activated by clicking

1. "MTS option" on the "RF Data Converter Subsystem: DAC" bar

2. Click the Sync Array (0) (1) (2) (3) --> Apply-->Synchronise

Error light does not turn red; SysRef Enable light turns green 

3. Windows-->Multiview-->DAC FFT 

4.  Change the CF to 150 MHz for DAC Tile0 DAC0 DAC1 DAC2 DAC3 --> Generate all

5. Connect DAC0 Positive to Spectrum Analyzer (R&S FSP 9KHz to 40GHz)

The output is observed as attached Picture (CF_150M_MTS_SingleOut.png, 1st pic)

DAC0 VOUT_P VOUT_N, DAC1 VOUT_P VOUT_N shows the same spectrum.

 

6. I also try do the Non-MTS mode, only the second harmonic appears.

Please check the the attached picture (CF_150M_NONMTS_SingleOut.png, 2nd pic)

 

I was wondering if there is any step that looks weird from your side, please kindly advice.

 

I remember in ZCU 111, to enable MTS mode, one should bypass the PLL for all tiers and set the clock frequency to a specific frequency, then the MTS can be activated without errors. However, I do not see such option in the ZCU 216.

GUI version: RFEvalTool v2.3

Many thanks for your time again.

CF_150M_MTS_SingleOut.png
CF_150M_NONMTS_SingleOut.png
0 Kudos
Highlighted
Moderator
Moderator
157 Views
Registered: ‎04-18-2011

Hi @cclinrichard 

You are correct about ZCU111. there was only 1 Sample clock frequency. I need to check on what is allowed for 216. 

Can you tell me what the DAC tile set up here is? where is the data coming from BRAM or DDR?

It looks to me like this is either down to the data rate on the PL interface or the clocking on the RF side (is it the same for you non-mts mode)

 

Keith 

-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
Highlighted
Visitor
Visitor
127 Views
Registered: ‎06-12-2020

Hi @klumsde ,

 

Thanks for your reply!

The output is DAC tile0, with default settings.

FIFO data: real, interpolation: 1X, Mixer: Bypass, Crossbar: Real-Single-Band, QMC Gain/phase: Disabled, inverse Sinc: Disabled. 

Memory type: BRAM.

Thanks and looking forward to your reply.

0 Kudos