cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
damen_red
Newbie
Newbie
848 Views
Registered: ‎03-01-2019

ZCU111 ADC Capture sample depth

Jump to solution

Hello, I am trying to perform a capture of a modulated signal similar to the one in this example from Xilinx:

https://www.xilinx.com/video/events/rfsoc-gen3-rf-data-converter-5g-nr-performance.html

I am using the ZCU111(with DC UI v1.6), this example uses the ZCU208(with DC UI v2.2). I recognize that these are two different sets of hardware/software. My question is, am I able to do a capture similar to this one? I don't see an option to export when right clicking in the ADC window, and the export function from the main menu only gives me about 32k of data, which is not enough for me to evaluate one frame. How can I achieve this with the ZCU111 out of the box?

 

Tags (1)
0 Kudos
1 Solution

Accepted Solutions
damen_red
Newbie
Newbie
769 Views
Registered: ‎03-01-2019

Yes, this was exactly my issue, thanks!

View solution in original post

7 Replies
klumsde
Moderator
Moderator
779 Views
Registered: ‎04-18-2011

In the evaluation design on ZCU111 you have two capture memory options. 

If you can only get 32K in IQ mode then it is most likely because you are using the BRAM to capture the data. 

In this case you need to change the capture memory to DDR. 

klumsde_0-1603925466692.png

The maximum sample size allowed is dependent on the design. The design return an error or a
warning if the maximum size is exceeded. The DDR mode supports up to 128M real samples per
channel, but has limitations on the data rates. This limitation on the data rates comes from
different aspects of the software design and not from the Zynq UltraScale+ RFSoC.

should give you 64M capture for these IQ modes 

-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
damen_red
Newbie
Newbie
770 Views
Registered: ‎03-01-2019

Yes, this was exactly my issue, thanks!

View solution in original post

klumsde
Moderator
Moderator
760 Views
Registered: ‎04-18-2011

OK can you please Mark the reply as the solution so others can find it useful

-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
damen_red
Newbie
Newbie
749 Views
Registered: ‎03-01-2019

Now I see that the DAC output seems to be a different format when switching to DDR, or at least to me appears that there is some non-coherence in the sine wave. Is there anything else I need to know when switching to DDR capture?

0 Kudos
klumsde
Moderator
Moderator
694 Views
Registered: ‎04-18-2011

Can you share the spectrum here?

Can you also share the settings for the DAC tile, what is the data rate of the DAC input bus here. 

Try changing the interpolation factor here to see if it cleans it up. if that happens then the problem is with the DDR data rates. 

 

-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
damen_red
Newbie
Newbie
637 Views
Registered: ‎03-01-2019

Here are two spectrum captures hopefully depicting my issue. The first one is from a fresh bring up of the tool with default configuration and 200MHz tone(which is the default). Only thing I do is "generate" and "acquire". The default being BRAM, I then switch to DDR and hit "generate" and "acquire" again, resulting in the second spectrum.

BRAM CaptureBRAM CaptureDDR CaptureDDR Capture

0 Kudos
klumsde
Moderator
Moderator
627 Views
Registered: ‎04-18-2011

Hi @damen_red 

Increase your decimation factor here. 

I expect this is an issue with the BW of the DDR interface. 

 

Keith 

-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos