UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Observer sigan
Observer
388 Views
Registered: ‎05-28-2019

Zynq UltraScale+ | Xilinx Power Estimatior (XPE) | Unable to import Vivado 2019.1.2 exported file

Jump to solution

Hi, I'm trying to import Vivado 2019.1.2 exported power file to Xilinx Power Estimator (XPE). Nothing happens when I try to import, nothing gets filled in, no error or warning message.

Macros are enabled, so that should be fine I think since the buttons work...

Although some fields in the spreadsheet are not looking fine, Summary -> Power Supply -> Total (A) fields are filled with #VALUE!bilde.png

Does this indicate bad health of spreadsheet?

Setup is as follows:
****** Vivado v2019.1.2 (64-bit)
**** SW Build 2615518 on Fri Aug 9 15:55:25 MDT 2019
**** IP Build 2614745 on Fri Aug 9 20:55:02 MDT 2019
** Copyright 1986-2019 Xilinx, Inc. All Rights Reserved.

Running Office 365 on Windows 10 Pro

XPE spreadsheet: UltraScale_Plus_XPE_2019_1_2.zip from
https://www.xilinx.com/products/technology/power/xpe.html

0 Kudos
1 Solution

Accepted Solutions
Xilinx Employee
Xilinx Employee
279 Views
Registered: ‎08-25-2010

回复: Zynq UltraScale+ | Xilinx Power Estimatior (XPE) | Unable to import Vivado 2019.1.2 exported file

Jump to solution

Hi @sigan 

I am also running office 365 and win10. which language is setting?

IMPORTANT: On Windows, make sure your language is set to English. Select Control Panel >Clock,
Language, and Region > Region and Language, and set Format to English.

 

Thanks
Simon
-------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------

View solution in original post

0 Kudos
6 Replies
Xilinx Employee
Xilinx Employee
354 Views
Registered: ‎08-25-2010

回复: Zynq UltraScale+ | Xilinx Power Estimatior (XPE) | Unable to import Vivado 2019.1.2 exported file

Jump to solution

Hi @sigan 

Can you upload the .xpe for reproducing this issue?

Thanks
Simon
-------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
Observer sigan
Observer
340 Views
Registered: ‎05-28-2019

回复: Zynq UltraScale+ | Xilinx Power Estimatior (XPE) | Unable to import Vivado 2019.1.2 exported file

Jump to solution

Hi @simon , xpe files exported from Vivado 2019.1.2 are attached.

Thank you so much for looking into this!

0 Kudos
Xilinx Employee
Xilinx Employee
316 Views
Registered: ‎08-25-2010

回复: Zynq UltraScale+ | Xilinx Power Estimatior (XPE) | Unable to import Vivado 2019.1.2 exported file

Jump to solution

Hi @sigan 

I can see the power number for each, please see the attached XPE

2019.2PNG.PNG

Thanks
Simon
-------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
Observer sigan
Observer
295 Views
Registered: ‎05-28-2019

回复: Zynq UltraScale+ | Xilinx Power Estimatior (XPE) | Unable to import Vivado 2019.1.2 exported file

Jump to solution

Hi @simon, I opened the spreadsheet attached and I still get the "#VALUE!" in the "Total (A)" column in the "Power supply" section of the Summary sheet and I
still cannot import exported data from Vivado 2019.1.2 tool into the XPE spreadsheet. So I think there is some kind of issue with the settings of my Office 365
and the spreadsheet causing it to not operate properly. I want to get to the bottom of this so we can export design data from Vivado and import into XPE without
any hassel in the future.

Are you running Office 365?
Are there any other settings in Excel I should be aware of other the the "Allow all macros" mentioned on the XPE web page: https://www.xilinx.com/products/technology/power/xpe.html

Other things I have tried without any luck:
i) Tried running on my secondary work machine, that is Windows 7 & Excel 365.
ii) Tried deleting all .exd files on C drive, https://www.xilinx.com/support/answers/63366.html
iii) Tried debugging the excel cells that are showing "#VALUE!", but they are password protected. According to Microsoft (https://support.office.com/en-us/article/how-to-correct-a-value-error-15e1b616-fbf2-4147-9c0b-0a11a20e409e)
the "#VALUE!" "The error is very general, and it can be hard to find the exact cause of it."

Is there any way I can be provided with the spreadsheet password so that I can try to pinpoint more accurately what the problem is?

0 Kudos
Xilinx Employee
Xilinx Employee
280 Views
Registered: ‎08-25-2010

回复: Zynq UltraScale+ | Xilinx Power Estimatior (XPE) | Unable to import Vivado 2019.1.2 exported file

Jump to solution

Hi @sigan 

I am also running office 365 and win10. which language is setting?

IMPORTANT: On Windows, make sure your language is set to English. Select Control Panel >Clock,
Language, and Region > Region and Language, and set Format to English.

 

Thanks
Simon
-------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------

View solution in original post

0 Kudos
Observer sigan
Observer
270 Views
Registered: ‎05-28-2019

回复: Zynq UltraScale+ | Xilinx Power Estimatior (XPE) | Unable to import Vivado 2019.1.2 exported file

Jump to solution

Yes, setting format to English makes the spreadsheet work. Thanks a lot!

bilde.png

0 Kudos