cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
marcoventurini
Adventurer
Adventurer
387 Views
Registered: ‎10-02-2014

DPHY TX lane disable

Jump to solution

Hello,

We configured the mipi DPHY tx ip with 4 lanes.

In some configuration we need to use only one lane in HS mode.

When all the lanes are active everything is OK, but when some of the lanes are disabled the "ready" signal is never asserted again

after the first packet.

Is this behavior expected?

Thanks,

Marco

badbadgoodgood

 

 

Tags (1)
0 Kudos
1 Solution

Accepted Solutions
karnanl
Xilinx Employee
Xilinx Employee
361 Views
Registered: ‎03-30-2016

Hello Marco @marcoventurini 

Did you enable "Active lanes support" in the GUI ?
DPHY_TX_enable_act_lane.jpg

Did you set "active_lanes_in" when output is in LP-11 state ?

Enable_active_lanes_when_LP11.jpg


Thanks & regards
Leo


------------------------------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
If starting with Versal take a look at our Versal Design Process Hub and our Versal Blogs
Versal Example Designs : LINK
>>------------------------------------------------------------------------------------------------

View solution in original post

2 Replies
karnanl
Xilinx Employee
Xilinx Employee
362 Views
Registered: ‎03-30-2016

Hello Marco @marcoventurini 

Did you enable "Active lanes support" in the GUI ?
DPHY_TX_enable_act_lane.jpg

Did you set "active_lanes_in" when output is in LP-11 state ?

Enable_active_lanes_when_LP11.jpg


Thanks & regards
Leo


------------------------------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
If starting with Versal take a look at our Versal Design Process Hub and our Versal Blogs
Versal Example Designs : LINK
>>------------------------------------------------------------------------------------------------

View solution in original post

marcoventurini
Adventurer
Adventurer
337 Views
Registered: ‎10-02-2014

That was the problem, I overlooked this setting, sorry.

Thanks for your support.

Marco