cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Adventurer
Adventurer
174 Views
Registered: ‎10-02-2014

DPHY TX lane disable

Jump to solution

Hello,

We configured the mipi DPHY tx ip with 4 lanes.

In some configuration we need to use only one lane in HS mode.

When all the lanes are active everything is OK, but when some of the lanes are disabled the "ready" signal is never asserted again

after the first packet.

Is this behavior expected?

Thanks,

Marco

badbadgoodgood

 

 

Tags (1)
0 Kudos
1 Solution

Accepted Solutions
Highlighted
Xilinx Employee
Xilinx Employee
148 Views
Registered: ‎03-30-2016

Re: DPHY TX lane disable

Jump to solution

Hello Marco @marcoventurini 

Did you enable "Active lanes support" in the GUI ?
DPHY_TX_enable_act_lane.jpg

Did you set "active_lanes_in" when output is in LP-11 state ?

Enable_active_lanes_when_LP11.jpg


Thanks & regards
Leo

View solution in original post

2 Replies
Highlighted
Xilinx Employee
Xilinx Employee
149 Views
Registered: ‎03-30-2016

Re: DPHY TX lane disable

Jump to solution

Hello Marco @marcoventurini 

Did you enable "Active lanes support" in the GUI ?
DPHY_TX_enable_act_lane.jpg

Did you set "active_lanes_in" when output is in LP-11 state ?

Enable_active_lanes_when_LP11.jpg


Thanks & regards
Leo

View solution in original post

Highlighted
Adventurer
Adventurer
124 Views
Registered: ‎10-02-2014

Re: DPHY TX lane disable

Jump to solution

That was the problem, I overlooked this setting, sorry.

Thanks for your support.

Marco