cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
bsarbb
Observer
Observer
206 Views
Registered: ‎03-11-2021

Debugging Video IP Output With ILA

Hello,

I am trying to debug the output of hdsdi-rx subsystem. I added ILA to our design as shown below:

ila_bd.png

And I configure system ila just like explained in "Video Series 31 – Debugging a Video System using an ILA".

Then I generated bitstream, exported hardware, and compiled petalinux project with resulting ".xsa" file. Linux starts to run on hardware after all this works. After this, I opened Vivado and clicked to "Open Hardware Manager". The following screen appeared :

ila_screenshot.png

I added trigger and clicked the run trigger button, but nothing changed. Core status remains in the "Waiting for Trigger" state. 

How can I get rid of this problem ? 

Thanks,

0 Kudos
3 Replies
Nikhil_Thapa
Explorer
Explorer
196 Views
Registered: ‎05-28-2020

Hi @bsarbb ,

It depends on the trigger condition you applied for that signal. If the condition is not fulfilled for triggering the ILA, then it always remains at "waiting for trigger" state. 

Nikhil_Thapa_2-1618472426860.png

 

How can I get rid of this problem ? 

No, this is not the problem. This is usual. The ILA is just waiting to be triggered, based on the triggering condition. To get rid of this, you can try changing the trigger condition for that signal to trigger the ILA. 

Or

simply run the ILA by clicking on icon, PLAY button, as shown below. By doing this, ILA will be triggered to capture the signal without applying any trigger condition.

Nikhil_Thapa_1-1618472358985.png

 

Thanks and Regards,

 

nikhil@logictronix.com
:::::Do not forget to Accept as solution, give Kudo and Share a post that you think is helpful:::::
bsarbb
Observer
Observer
175 Views
Registered: ‎03-11-2021

Sorry for early question.

I just try to capture frame from terminal with yavta command after all these thing and ILA worked.

florentw
Moderator
Moderator
156 Views
Registered: ‎11-09-2015

HI @bsarbb 

It make sense. You are trying to trigger on a start of frame (tuser). So only if there is a frame transmitted you will have the ILA triggered


Florent
Product Application Engineer - Xilinx Technical Support EMEA
**~ Don't forget to reply, give kudos, and accept as solution.~**