cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
deepg799
Explorer
Explorer
1,012 Views
Registered: ‎01-20-2019

How to disable PLL shutdown

Jump to solution

I loaded Linux image generated from petalinux 2018.2 with the custom board.

After the plugin Displayport monitor, I can see the desktop.

But when I keep the system without any movement or only run some program, after 10minutes, Display will shutdown automatically.

And output log:

PLL: shutdown

Which program will turn off the display automatically? how can I disable auto screen off?

Thanks!

0 Kudos
1 Solution

Accepted Solutions
deepg799
Explorer
Explorer
900 Views
Registered: ‎01-20-2019

@aoifem we can disable the DP monitor display timeout permanently by running the below commands after exporting the display.

xset s 0 0 

xset dpms 0 0 0 

View solution in original post

2 Replies
aoifem
Moderator
Moderator
994 Views
Registered: ‎11-21-2018

Hi @deepg799 

Can you try using the following commands: 
Export DISPLAY=:0
xset dpms force on

I believe this is actually a Linux issue. I think the problem might be related to the HPD event (Hot Plug Detect). At boot up or when the monitor is unplugged and plugged back in, it will turn on.  But after some time it will disable once the DPMS timeout has been reached.  You can then turn it back on using the commands above. 

I think you can permanently disable the timeout in the xorg.conf file. This is outlined in the following wiki page:

https://xilinx-wiki.atlassian.net/wiki/spaces/A/pages/18842097/Xilinx+DRM+KMS+MIPI+DSI2-Tx+Driver

 

If you encounter more issues with this or need more information, I would encourage you to search the Linux documentation.

Please let me know if that solves your issue. 

 

Regards, 

Aoife 

 

Aoife
Product Application Engineer - Xilinx Technical Support EMEA


**~ Got a minute? Answer our Vitis HLS survey here! ~**

**~ Don't forget to reply, give kudos, and accept as solution.~**
deepg799
Explorer
Explorer
901 Views
Registered: ‎01-20-2019

@aoifem we can disable the DP monitor display timeout permanently by running the below commands after exporting the display.

xset s 0 0 

xset dpms 0 0 0 

View solution in original post