cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Adventurer
Adventurer
1,112 Views
Registered: ‎06-05-2019

MIPI example design’ problems on ZCU102

I used the MIPI CSI-2 RX subsystem example design and did not make any change. I used the IMX-274 sensor and the vivado version is 2019.1. The video output from HDMI are as follow. These photos were taken on a mobile phone and the picture quality is a bit low. Generally speaking, there are some colorful and strange colors in some places in the picture and the picturea are very unclear.

 

微信图片_20191225130917.jpg微信图片_20191225130920.jpg

微信图片_20191225131049.jpg微信图片_20191225131052.jpg

And I modified the project to fit my camera sensor. This sensor is a mono camera sensor and the video output from HDMI are as follow. The result is similar to the video produced by imx274.

微信图片_20191225130913.jpg微信图片_20191225130915.jpg

Tags (2)
0 Kudos
13 Replies
Highlighted
Mentor
Mentor
1,082 Views
Registered: ‎06-16-2013

Re: MIPI example design’ problems on ZCU102

Hi @ivanfan 

 

Would you make sure color space and pixel map ?

Especially, make sure color mode on your HDMI monitor.

 

Best regards,

0 Kudos
Highlighted
Adventurer
Adventurer
1,067 Views
Registered: ‎06-05-2019

Re: MIPI example design’ problems on ZCU102

Thank you for your reply @watari 

I can get the following message from the program: 

微信截图_20191225161311.png

And I don't know how to change the color mode on the HDMI monitor. I used another monitor and got similar result.

I saw the output of the example design on other posts. The picture he sent was clear and no strange color but just greenish.

https://forums.xilinx.com/t5/存储接口-视频/MIPI接口技术开发相关问题-画像显示偏绿色/m-p/1050790#M1011 

微信截图_20191225170942.png

0 Kudos
Highlighted
Mentor
Mentor
1,002 Views
Registered: ‎06-16-2013

Re: MIPI example design’ problems on ZCU102

Hi @ivanfan 

 

I red your reference post and your message on it.

According to this post, image sensor doesn't have any pre-image procedures.

So, at least you need to implement some image procedures. (ex. white balance, bayer filter and so on)

 

In your case, it seems that you confirm white balance setting, bayer filter and color space which I already mentioned.

 

Would you try it ?

 

Best regards,

Highlighted
Moderator
Moderator
954 Views
Registered: ‎08-01-2007

Re: MIPI example design’ problems on ZCU102

Are you using one of Xilinx demos? Did you change the camera settings, changing camera settings can get a good quality.

Highlighted
Adventurer
Adventurer
921 Views
Registered: ‎06-05-2019

Re: MIPI example design’ problems on ZCU102

Thank you for your reply.

Yes, I used the mipi csi-2 rx subsystem example design introduced in PG232.

Now it seems to be a problem with the vivado project because the same problem occurs when I change the camera. I suspect that the decoding error of mipi signal caused some problems in the color space. But I don't know how to modify it.

I didn’t make any changes to the example design when using the IMX274 sensor. I don’t know why I get different results than others

0 Kudos
Highlighted
Moderator
Moderator
859 Views
Registered: ‎08-01-2007

Re: MIPI example design’ problems on ZCU102

Check your hardware, are they the same with the HW in Table 5-1 of PG232 chaoter 5?

 

Highlighted
Adventurer
Adventurer
790 Views
Registered: ‎06-05-2019

Re: MIPI example design’ problems on ZCU102

Yes, I use zcu102 and IMX274 camera sensor recommended in PG232

微信图片_20200108115617.jpg

0 Kudos
Highlighted
Xilinx Employee
Xilinx Employee
735 Views
Registered: ‎03-30-2016

Re: MIPI example design’ problems on ZCU102

Hello @ivanfan 

What is the version of your ZCU102 board ?

Regards
Leo

0 Kudos
Highlighted
Adventurer
Adventurer
715 Views
Registered: ‎06-05-2019

Re: MIPI example design’ problems on ZCU102

Thank you for your reply @karnanl 

 My board's version is 1.1. The recommend version in PG232 is 1.0. Will the difference of the borads'version affect the mipi decoding? How should I modify my project?

Any idea will be appreciated.

0 Kudos
Highlighted
Xilinx Employee
Xilinx Employee
690 Views
Registered: ‎03-30-2016

Re: MIPI example design’ problems on ZCU102

Hello @ivanfan 

To be honest I've never use ZCU102 rev1.1.

Questions
1. Do you have access to ZCU102 rev1.0 ?
2. Do you have access to DSI Panel  (AUOS display panel (B101UAN01.7_H/W 1A)?
    # I am suspecting that your HDMI monitor may cause this issue....


Regards
Leo

Highlighted
Mentor
Mentor
686 Views
Registered: ‎06-16-2013

Re: MIPI example design’ problems on ZCU102

Hi @ivanfan and @karnanl 

 

It is useful information about this issue.

 

The figure of sub-pixel is different between normal LCD panel and DSI's LCD panel.

 

In this case, as @karnanl already mentioned, it might be route cause.

Would you make sure the figure of sub-pixel in data sheet ?

 

Best regards,

 

 

Highlighted
Xilinx Employee
Xilinx Employee
603 Views
Registered: ‎03-30-2016

Re: MIPI example design’ problems on ZCU102

Hello @ivanfan 

ZCU102 rev1.1 is working in our labs. (using HDMI output)
zcu102-rev1.1.jpg

I am not a panel expert. Perhaps hints from @watari  above can direct you to the problem root-cause.

Thanks
Leo

Highlighted
Moderator
Moderator
555 Views
Registered: ‎10-04-2017

Re: MIPI example design’ problems on ZCU102

Hi @ivanfan,

Are you still running into an issue?

To summarize the thread:

  • You are running into a color issue as shown in the first images.

  • Vivado 2019.1
  • ZCU102 rev1.1
  • Tested multiple HDMI monitors
  • Tested multiple FMC cameras

As I understand, the image below is from an example and not your system. Is this correct?

2020-01-22 07_40_22-Re_ MIPI example design’ problems on ZCU102 - Community Forums.png

Moving forward:

Can you try rebuilding the Vivado project and elf? I don't expect this to be an issue, but it is an easy double-check.

Next, can you test your HDMI cable? And possibly the HDMI output port of your ZCU102? There are many designs that use the HDMI port, you can use the HDMI example design in chapter 5 of the HDMI PG, or most of our TRDs also use the HDMI connection.

 

Thanks and regards,

Don't forget to reply, kudo, and accept as solution.

Xilinx Video Design Hub