cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Explorer
Explorer
1,041 Views
Registered: ‎04-21-2017

Modifying IP properties

Jump to solution

Dear Forum,

 

I need to force Vivado 2017.3 to pull in v3 of the HDMI IP as opposed to v2, which is the default.

 

http://www.wiki.xilinx.com/Xilinx+V4L2+hdmirx+driver#Related%20Links-Change%20Log

 

At the bottom of this page there is a note to say that Properties must be modified to pull-in v3 version of the IP's..

 

For any given project, where would I find the following IP properties so that I can edit them?

 

  • Hdmi_rx_ss: C_HDMI_VERSION 3
  • Vid_Phy: C_INT_HDMI_VER_CMPTBLE 3

 

Regards,

 

David

Tags (3)
0 Kudos
1 Solution

Accepted Solutions
Highlighted
Moderator
Moderator
1,157 Views
Registered: ‎11-09-2015

Hi @dje666,

 

I recommend you to move to 2018.1. The drivers are ready for HDMI. And of course the BSPs are already available for ZCU102 and ZCU106


Florent
Product Application Engineer - Xilinx Technical Support EMEA
**~ Don't forget to reply, give kudos, and accept as solution.~**

View solution in original post

0 Kudos
3 Replies
Highlighted
Moderator
Moderator
995 Views
Registered: ‎11-09-2015

HI @dje666,

 

Quick question: Why not using a version of vivado which has the v3? It will (really) much easier and might avoid issues


Florent
Product Application Engineer - Xilinx Technical Support EMEA
**~ Don't forget to reply, give kudos, and accept as solution.~**
0 Kudos
Highlighted
Explorer
Explorer
986 Views
Registered: ‎04-21-2017

Hi Florent,

 

Yes, switching to 2017.4 or later would be better, but I'm locked into 2017.3 right now, so instructions on how to proceed would be useful.

 

If I do make the move...... In your opinion which version of the Xilinx tools should I move to?

 

I need to ensure that I have board-support, BSP support PetaLinux support and driver support for HDMI IP in MPSoC-EV devices running on ZCU102 and ZCU106 dev-kits.

 

TTFN.

 

DJE666

0 Kudos
Highlighted
Moderator
Moderator
1,158 Views
Registered: ‎11-09-2015

Hi @dje666,

 

I recommend you to move to 2018.1. The drivers are ready for HDMI. And of course the BSPs are already available for ZCU102 and ZCU106


Florent
Product Application Engineer - Xilinx Technical Support EMEA
**~ Don't forget to reply, give kudos, and accept as solution.~**

View solution in original post

0 Kudos