cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Participant
Participant
1,086 Views
Registered: ‎04-25-2017

UG1209 prebuilt image not working with supported monitor

Jump to solution

Hello there,

 

  I'm trying to get the prebuilt image of example 2 (tricube) from the design files of UG1209 (v2018.2) working on zcu102 eval board revision 1.0.  The tricube application runs fine but the monitor cannot detect any signal.  Searching around the forum, I found that there is a list of supported monitors according to AR#68671.  It happens I have a DELL P2414Hb around so I tried with it again.  However, the monitor still can't detect any signal. 

  The Xorg.0.log shows unable to find connected outputs.  Since I'm using a supported monitor and a prebuild image, I don't think it is a compatibility issue.   Could there be any configuration that I need to do for Xorg to get this work?  Attached is the Xorg.0.log and dmesg.txt.  Thank you for any help or suggestions.  

 

Li

 

Xorg.0.log sections
[ 40.571] (II) ARMSOC(0): Got CRTC: 0 (id: 36)
[ 40.590] (II) ARMSOC(0): Output DP-1 has no monitor section
[ 40.609] (II) ARMSOC(0): EDID for output DP-1
[ 40.609] (II) ARMSOC(0): Output DP-1 disconnected
[ 40.609] (WW) ARMSOC(0): No outputs definitely connected, trying again...
[ 40.609] (II) ARMSOC(0): Output DP-1 disconnected
[ 40.609] (WW) ARMSOC(0): Unable to find connected outputs - setting 1024x768 initial framebuffer

 

 

 

 

 

 

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Teacher
Teacher
1,058 Views
Registered: ‎06-16-2013

Hi @lizhang86

 

What kind of cable do you use ? Use DisplayPort cable ?

 

Accordning to log files, it seems that it failed "reading EDID".

 

In this case, you should use DisplayPort Cable to connect your LCD monitor via DP or use an active adapter to connect your LCD monitor via HDMI...

 

Best regards,

 

View solution in original post

0 Kudos
4 Replies
Highlighted
Teacher
Teacher
1,059 Views
Registered: ‎06-16-2013

Hi @lizhang86

 

What kind of cable do you use ? Use DisplayPort cable ?

 

Accordning to log files, it seems that it failed "reading EDID".

 

In this case, you should use DisplayPort Cable to connect your LCD monitor via DP or use an active adapter to connect your LCD monitor via HDMI...

 

Best regards,

 

View solution in original post

0 Kudos
Highlighted
Participant
Participant
1,042 Views
Registered: ‎04-25-2017
Hi @watari
Thank you. I was using a Displayport to DVI cable. I will order a dp to dp cable and give it a try.
Li
0 Kudos
Highlighted
Participant
Participant
997 Views
Registered: ‎04-25-2017

Hello,

    Tried the design with the DP to DP cable, everything works fine.  Thanks for all the help.

 

Li

0 Kudos
Highlighted
Moderator
Moderator
983 Views
Registered: ‎11-09-2015

HI @lizhang86,

 

As everything is working for you now, could you kindly mark @watari's reply as accepted solution to close the topic (click on "Accept as solution" button below the reply while logged in)?

Thanks and Regards,


Florent
Product Application Engineer - Xilinx Technical Support EMEA
**~ Don't forget to reply, give kudos, and accept as solution.~**
0 Kudos