cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
gefei-liuqi
Adventurer
Adventurer
227 Views
Registered: ‎10-21-2018

VCU encode 4 streams,does not smoothly

Jump to solution

Hello, My petalinux is 2019.1, zcu106-bsp.

 I encode 4 streams simultaneously, with resolution 960x544.

Use gstreamer commands like this:

 gst-launch-1.0 v4l2src device=/dev/video0 io-mode=4 ! video/x-raw,format=NV12,width=960,height=544,framerate=25/1 ! omxh264enc gop-length=1 b-frames=0 periodicity-idr=1 num-slices=2 target-bitrate=4000  ! testH264inteval ! fakesink

  There are four commands like this, with device /dev/video0, /dev/video1, /dev/video2, /dev/video3

 testH264interval is my gstreamer plug-in.  It will calculate the time-interval between sequence-encoded frames sended from omxh264enc.

   Theoetically, the time-intervals should be 40ms.   But actually, the time-intervals always over 40ms, sometimes even over 60ms.  This situation exists in each Gstreamer-pipelines.

   Is that because of  vcu''s latency?  How can we deal with it?

Tags (1)
0 Kudos
1 Solution

Accepted Solutions
watari
Teacher
Teacher
209 Views
Registered: ‎06-16-2013

Hi @gefei-liuqi 

 

It depends on your setting on omxh264enc and alignment setting.

In this case, because there are some performance issue on your pipeline, it occurred.

 

So, I ask you what is your achievement ? Constant bitrate ? Low latency ? ...

 

Best regards,

View solution in original post

1 Reply
watari
Teacher
Teacher
210 Views
Registered: ‎06-16-2013

Hi @gefei-liuqi 

 

It depends on your setting on omxh264enc and alignment setting.

In this case, because there are some performance issue on your pipeline, it occurred.

 

So, I ask you what is your achievement ? Constant bitrate ? Low latency ? ...

 

Best regards,

View solution in original post