cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
chaitusvk
Adventurer
Adventurer
277 Views
Registered: ‎02-15-2019

Video Mixer layer 1 video is Running multiple times

Jump to solution

HI ,

i am newbie to video processing , i want to overlay Time on video to do this  i generated video with time with 640X480 at 60hz with 25MHz clock , and Mixing this with 1920X1080 at 148.5MHZ  video with Video mixure ip.

When i check my Time video ip  with VGA source ,Video to axi , VDMA ,AXI to video  it is working fine .Time VideoTime Video

 

When i combine with Master video which is running at 148.5 mhz .. My time video is running multiple times 

Mixed videoMixed video

i am running axi at 148.5mhz and axi to video also at 148.5MHZ  

i have enclosed video also 

MY question is how to avoid this moving of my text in my combined video .. how to make it static 

please help me @florentw 

0 Kudos
1 Solution

Accepted Solutions
reaiken
Explorer
Explorer
247 Views
Registered: ‎07-18-2011

@chaitusvk 

You have to synchronize your overlay source and incoming video source to the output frame rate.

This is typically done by using a triple-buffer in memory for the video input sources and synchronizing the read side and the overlay with a vertical interrupt from the output VTC.  

If the overlay is already generated using timing from the output VTC, the overlay synchronization step is not necessary, just the incoming video needs to be synchronized because it is from a different clock/frame rate.

View solution in original post

2 Replies
reaiken
Explorer
Explorer
248 Views
Registered: ‎07-18-2011

@chaitusvk 

You have to synchronize your overlay source and incoming video source to the output frame rate.

This is typically done by using a triple-buffer in memory for the video input sources and synchronizing the read side and the overlay with a vertical interrupt from the output VTC.  

If the overlay is already generated using timing from the output VTC, the overlay synchronization step is not necessary, just the incoming video needs to be synchronized because it is from a different clock/frame rate.

View solution in original post

chaitusvk
Adventurer
Adventurer
208 Views
Registered: ‎02-15-2019

Thank you very much @reaiken

 

Screenshot from 2021-03-23 10-22-11.png 

will connecting VTC Fysnc to mm2s_fsync  solve my problem ...

0 Kudos