cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
ericzerbib
Adventurer
Adventurer
164 Views
Registered: ‎09-05-2018

Video image issue when using videocrop

Hello forum/support

I want to develop a VideoWall application using SDK 2019.2, I have a stream 4K60 that I want to display to 4 monitors (2X2)

 

my first idea was to use the videocrop pluggin provided with gstreamer

Using this kind of command

GST_DEBUG=*:3 gst-launch-1.0 --no-fault rtspsrc location=rtsp://192.168.68.78:555/stream latency=300 name=demux demux. ! rtph264depay ! h264parse ! queue max-size-buffers=0 max-size-bytes=0 ! omxh264dec internal-entropy-buffers=2 low-latency=false ! queue max-size-bytes=0 ! videocrop right=1920 bottom=1080 ! kmssink render-delay=0 bus-id=a0090000.v_mix plane-id=30  demux. ! rtpmp4adepay ! faad ! audioconvert ! audioresample ! "audio/x-raw, rate=48000, channnels=2, format=S24_32LE" ! alsasink render-delay=0 device=hw:1,0

It work well fro the first (TOP-LEFT) monitor but for other monitors

for example TOP-RIGHT I change the videocrop plugin's parameters like this

... ! videocrop left=0 right=1920 top=0 bottom=1080 ! ...

But the video is a kind of green/purple video with supper position of multiple images, I tried also other combination (Bottom-left, and bottom-right) but all the three combination didn't worked same problem of colors...

My stream is from a Ultrascale Xilinx encoder h264 NV12, my decoder UltraScale Xilinx Decoder

using videocropusing videocrop

 

Any idea on the issue?

I saw that in the past (2018.3) a bug has been fixed in the DMA when using videocrop in gstreamer pipline but my version is 2019.2

 

Tags (2)
0 Kudos
0 Replies