cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Explorer
Explorer
1,490 Views
Registered: ‎04-19-2016

XAPP585 Receiver problem

Jump to solution

Dear All,

 

I am currently using the XAPP585 (v1.1.1) as an reference design in my custom-design Cameralink Receiver IP. The IP basicly converts Cameralink base to Axi-Stream. I currently test this IP with my custom-design Zynq-board. I can successfully receive the 384*288,  16-bit images @120Hz test-images that its content are already known. But, 'sometimes' a problem is seen. Problem type is fortunatelly same all the time. 

 

  • In the 7000th frame (all 6999 frames received without any problem ),  128th pixel is missed and all others after this pixel is one location shifted to the right with their correct values in the first line
  • Above problem is seen in 120000th frame in another try. And seen in the one another try in 18000th frame. ( 'Try' means that just power-on and power-off board. )
  • Problem type is the same but, it is unknown in which frame (which time) it will be seen
  • Any suggestion about the this problem ? In fact,  I wonder that this app-note(XAP585) is withdrawn or something like obsolote?

Regards,

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Moderator
Moderator
1,825 Views
Registered: ‎11-09-2015

Re: XAPP585 Receiver problem

Jump to solution

Hi @doner_t,

 

The xapp585 should still work (not obsolete). Is there a way you can check it is not coming from your source?

 

Regards,

 

Florent


Florent
Product Application Engineer - Xilinx Technical Support EMEA
**~ Don't forget to reply, give kudos, and accept as solution.~**

View solution in original post

0 Kudos
3 Replies
Highlighted
Moderator
Moderator
1,826 Views
Registered: ‎11-09-2015

Re: XAPP585 Receiver problem

Jump to solution

Hi @doner_t,

 

The xapp585 should still work (not obsolete). Is there a way you can check it is not coming from your source?

 

Regards,

 

Florent


Florent
Product Application Engineer - Xilinx Technical Support EMEA
**~ Don't forget to reply, give kudos, and accept as solution.~**

View solution in original post

0 Kudos
Highlighted
Explorer
Explorer
1,430 Views
Registered: ‎04-19-2016

Re: XAPP585 Receiver problem

Jump to solution

Dear @florentw,

 

Thank you for reply. I am not sure that source maybe send like that. I will try to find possible problem reasons. 

 

Best Regards,

Tags (3)
0 Kudos
Highlighted
Scholar
Scholar
1,031 Views
Registered: ‎05-31-2012

Re: XAPP585 Receiver problem

Jump to solution

Hi @florentw  i experience troubles with this Xapp too.

What i observe is that the sampling point chosen by the state machine is not in the middle of the data eye but is at the transition.

In my case i have a 560 Mbit/s =1785 ps, the delay line is programmed with 23  (23x78ps = 1794 ps). 

I see the first transition for a delay of 20, the state machine calculates 20-23/2= 9 as the delay to apply to be in the middle of data eye.

What i see is that when decrementing the delay, data coming out from iserdes is stable (1100011).

When i reach a delay of 9, the data isn't stable anymore. Sometime the calculation can lead to a target delay of 10, and in that case works, but it can appear, as @doner_t noticed, that once in a while a corrupted frame appears.

 

i'm using Artix 7 

0 Kudos