cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
dzungpv
Newbie
Newbie
854 Views
Registered: ‎12-17-2017

XAPP794 upgrade to Vivado 2014.1

I am new in hardware design, but i am work in software for many year. Software always has backward with previous design but it not true with Vivado. I am working with XAPP794, i can build it with 2013.2 but i want to update to more recent version like 2013.3 or 2014.1 but failed after many try. To version 2013.3 error with fmc_imageon_vita_receiver.

Anyone success upgrade the xapp794 to more recent version?

Tags (1)
0 Kudos
2 Replies
balkris
Xilinx Employee
Xilinx Employee
845 Views
Registered: ‎08-01-2008

XAPP794 are expected to use in tested version . Can you elaborate error message in dettail based on your message we will try to help you

 

Please make sure to upgrade all the IPs used by XAPP

Thanks and Regards
Balkrishan
--------------------------------------------------------------------------------------------
Please mark the post as an answer "Accept as solution" in case it helped resolve your query.
Give kudos in case a post in case it guided to the solution.
0 Kudos
florentw
Moderator
Moderator
836 Views
Registered: ‎11-09-2015

Hi @dzungpv,

 

As @balkris, xapps are only supported for the version mentioned in the documentation.

 

Each version of vivado has a specific version for each IP. The xapp is build using a tcl script and tcl script need to mention the specific version of the IP. This is probably why it is not working for you.

 

The best way to use a newer version of vivado is to build the xapp794 with 2013.2 then open this project with a newer version of vivado. It should work. You might need to upgrade the IPs and make some required changes following the upgrade log.

 

Hope that helps,

 

Best Regards,

 

Florent


Florent
Product Application Engineer - Xilinx Technical Support EMEA
**~ Don't forget to reply, give kudos, and accept as solution.~**
0 Kudos