cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
chaol
Visitor
Visitor
7,571 Views
Registered: ‎05-20-2008

XSG 9.2 DDS5.0 problem

Hi,

I ran my model under system generator 9.2  today, there is an erroe messagge about DDC 5.0

 

--------------------------------- Version Log ----------------------------------
Version                                 Path
System Generator 9.2.01.1028            C:/Xilinx/dsptools/9.2.01.1028/sysgen
AccelDSP 9.2.01.1028                    C:/Xilinx/dsptools/9.2.01.1028/AccelDSP
Matlab 7.4.0.287 (R2007a)               C:/Matlab2007a
ISE 9.2.04i                             C:/Xilinx92i
ISE 9.2i IP Update 1                    C:/Xilinx92i
ISE 9.2i IP Update 2                    C:/Xilinx92i
--------------------------------------------------------------------------------
Summary of Errors:
Error 0001: Internal Error
     Block: 'ddc_new_fixedpoint_sundance6/FPGA DDC/DDS v5_0 '
--------------------------------------------------------------------------------

Error 0001:

Reported by:
  'ddc_new_fixedpoint_sundance6/FPGA DDC/DDS v5_0 '

Details:
An internal error occurred in the Xilinx Blockset Library.

Please report this error to Xilinx (http://support.xilinx.com),
in as much detail as possible. You may also find immediate help
in the Answers Database and other online resources at http://support.xilinx.com.


Error occurred during "Rate and Type Error Checking".

--------------------------------------------------------------------------------

 

 

But it worked before, and it can run totally OK under system generator 10.1.But I need use  system generator 9.2 to generate the VHDL code becuase our system compile the code using ISE9.2 chain. 

Or is that any compatible problem if I use system generator 10.1 to generate the model and use ISE 9.2 compile them.

 

Thanks and Best Regards,

Charlie 

0 Kudos
5 Replies
rjduran
Xilinx Employee
Xilinx Employee
7,564 Views
Registered: ‎08-02-2007

Sysgen models created with a newer version are not backwards compatible. The best thing to do is either go back to 9.2 and create the model or stick with 10.1.

What happens with the model in 10.1?

What do you mean it was working previously?  

RJ Duran
Customer Application Engineer
Technical Support: http://www.xilinx.com/support
Xilinx User Community: http://forums.xilinx.com
0 Kudos
chaol
Visitor
Visitor
7,558 Views
Registered: ‎05-20-2008

What happens with the model in 10.1?

 

This model can run very well in 10.1 

 

 

What do you mean it was working previously? 

 

When I post this question to you, I couldn't run this model. But now, after I restart the computer, the model can run again without any change.

I don't know why. It also happened before.

 

Thanks,

Charlie 

 

0 Kudos
chaol
Visitor
Visitor
7,547 Views
Registered: ‎05-20-2008

The screen snapshots are attached.
blockerror_DDS5.0.JPG
0 Kudos
chaol
Visitor
Visitor
7,545 Views
Registered: ‎05-20-2008

 
model.JPG
0 Kudos
chaol
Visitor
Visitor
7,544 Views
Registered: ‎05-20-2008

 
DDS config.JPG
0 Kudos