cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
273 Views
Registered: ‎11-15-2018

ZCU104 Vitis Smart Camera Demo not working

Hi,

I am trying to get the "Smart Camera" demo working. I have the same configuration as in https://github.com/Xilinx/Embedded-Reference-Platforms-User-Guide/blob/2019.2/Docs/operating-instructions.md 

I can ping from both sides (Windows laptop and from the board). When I try to run the ./demo.sh I get the following output:

 
0 Kudos
1 Reply
Highlighted
Moderator
Moderator
163 Views
Registered: ‎11-21-2018

Hi @marcos.martinez 

I am just adding some more details here in case there is anyone from the community facing the same issue. 

The messages you were seeing when you tried to execute the demo were as follows: 

Unable to get format: Inappropriate iotcl for device (25).
stream ready at rtsp://<IP>:8554/test.

You don't see anything on the DVI. When you tried to connect to the stream through VLC the demo halts with the message:

Load Xclbin Failed
[DNNDK:XRT] Bitstream download failed

-----------------------------------------------------------------------------------------------

As I explained to you privately, there is a known MIPI IP issue in the Smart Camera Demo as described in AR#73100.

https://www.xilinx.com/support/answers/73100.html

There is also alternative examples available in the Petalinux VCU for a ZCU104/106. If your camera shows up as a /dev/video node that supports YUV422, you could use those demos directly. There is an example in PG252 example-5 page 184 that might be useful also. 

Aoife
Product Application Engineer - Xilinx Technical Support EMEA
**~ Don't forget to reply, give kudos, and accept as solution.~**
0 Kudos