cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Contributor
Contributor
653 Views
Registered: ‎05-07-2018

Zynq UltraScale+ MPSoC VCU TRD 2018.3 - SDI Video Capture and SDI Display SDI-Rx link Problem

Jump to solution
 

Hello,

I tried to implement Zynq UltraScale+ MPSoC VCU TRD 2018.3 - SDI Video Capture and SDI Display project. I have a camera which have a HD-SDI output, max 1920x1080 and 1080p resolution and  max 30fps. After the boot part, I run this command :

xmedia-ctl  -d /dev/media0  -p

but according to reference page, Zynq can't recognize my SDI input, it says that :

Check resolution and frame-rate of "v_smpte_uhdsdi_rx_ss" node.

However when I checked the v_smpte_uhdsdi_rx_ss node in vivado project diagram, I saw that there is no option for frame rate and in configuration part there are 3 option for UHD-SDI Standard and they are : 3G-SDI, 6G-SDI,12G SDI 8DS

I also add my boot report as an attachment.In that file there are some errors like:

[ 10.852539] xilinx-video amba_pl@0:vcap_sdi: Entity type for entity a0080000.v_proc_ss was not initialized!

Media device information
--[ 66.244572] xilinx-sdirxss a0030000.v_smpte_uhdsdi_rx_ss: Video not locked!

p.s. : I changed frame rates in all of the config files as 30fps instead of 60fps.

I would really appreciate any help. Thanks in advance.

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Contributor
Contributor
583 Views
Registered: ‎05-07-2018
Hello again,
When I changed the board the problem was solved.

View solution in original post

0 Kudos
1 Reply
Highlighted
Contributor
Contributor
584 Views
Registered: ‎05-07-2018
Hello again,
When I changed the board the problem was solved.

View solution in original post

0 Kudos