cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
dehaze
Visitor
Visitor
433 Views
Registered: ‎10-13-2018

image enhancement v8.0 issues

Jump to solution

I am using xilinx image enhancement v8.0 in my porjects(Vivado 2018.3). Everything is OK except setting register 0x0020 via AXI interface.

If I am using no AXI-lite Register Interface mode,the  image enhancement works fine.

Because I needed to change the value of enhance strength,So I add AXI-lite Register Interface mode. Then I can change the  value Halo suppression,Anti-Alias,Image Edge Enhancement  via AXI interface in SDK,except setting register 0x0020 (acvtive size),register 0x0020 always 0. Even I use xil_out32 to change register 0x0020,the register is still 0.

why.

 

Tags (1)
0 Kudos
Reply
1 Solution

Accepted Solutions
florentw
Moderator
Moderator
370 Views
Registered: ‎11-09-2015

Hi @dehaze 

First note that the image enhancement v8.0  is a discontinued IP and there is no official support from Xilinx.

With that say, you probably forgot to set REG_UPDATE in the control register after changing the configuration:

 

enhancement.JPG

 


Florent
Product Application Engineer - Xilinx Technical Support EMEA
**~ Don't forget to reply, give kudos, and accept as solution.~**

View solution in original post

0 Kudos
Reply
2 Replies
florentw
Moderator
Moderator
371 Views
Registered: ‎11-09-2015

Hi @dehaze 

First note that the image enhancement v8.0  is a discontinued IP and there is no official support from Xilinx.

With that say, you probably forgot to set REG_UPDATE in the control register after changing the configuration:

 

enhancement.JPG

 


Florent
Product Application Engineer - Xilinx Technical Support EMEA
**~ Don't forget to reply, give kudos, and accept as solution.~**

View solution in original post

0 Kudos
Reply
aoifem
Moderator
Moderator
332 Views
Registered: ‎11-21-2018

Hi @dehaze 

If your question is answered or your issue is solved, please kindly mark the response which helped as a solution (click on "Accept as solution" button below the reply).

 

If this is not solved/answered, please reply in the topic giving more information on your current status.

 

Thanks and Regards,

Aoife
Product Application Engineer - Xilinx Technical Support EMEA
**~ Don't forget to reply, give kudos, and accept as solution.~**
0 Kudos
Reply