UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Contributor
Contributor
1,116 Views
Registered: ‎09-05-2018

Compatibility problem to decode some H264 stream encoded by imx6 encoder

Hello all

I'm using the VCU TRD 2018.2 I have some compatibility problem to decode some H264 stream encoded by imx6 encoder

my gstreamer pipeline is defined as following

root@zcu106_vcu_trd:~# GST_DEBUG=1,omx:9 gst-launch-1.0 -v rtspsrc location=rtsp://192.168.68.181:554/stream latency=200 name=demux demux. ! rtph264depay ! h264parse ! queue max-size-buffers=0 max-size-bytes=0 ! omxh264dec ! queue max-size-buffers=5 max-size-bytes=0 ! kmssink bus-id="a0070000.v_mix" sync=false

.. and the log of omxh264 is indicating an error on Setting decoder parameter at index 0x02000001

...

<omxh264dec-omxh264dec0> Set decoder parameter at index 0x02000001: Bad parameter (0x80001005)

How Can I understand which parameter cause the problem?

 

some log here/ attached full log

/GstPipeline:pipeline0/GstQueue:queue0.GstPad:src: caps = video/x-h264, stream-format=(string)byte-stream, alignment=(string)au, level=(string)3.1, profile=(string)constrained-baseline, width=(int)1280, height=(int)720, framerate=(fraction)0/1, interlace-mode=(string)progressive, chroma-format=(string)4:2:0, bit-depth-luma=(uint)8, bit-depth-chroma=(uint)8, parsed=(boolean)true
0:00:00.560568667  2922      0xa4008f0 DEBUG                    omx gstomx.c:1139:gst_omx_component_get_parameter:<omxh264dec-omxh264dec0> Getting decoder parameter at index 0x02000001
0:00:00.560643965  2922      0xa4008f0 DEBUG                    omx gstomx.c:1142:gst_omx_component_get_parameter:<omxh264dec-omxh264dec0> Got decoder parameter at index 0x02000001: None (0x00000000)
0:00:00.560679928  2922      0xa4008f0 DEBUG                    omx gstomx.c:976:gst_omx_component_get_state:<omxh264dec-omxh264dec0> Getting state of decoder
0:00:00.560715472  2922      0xa4008f0 DEBUG                    omx gstomx.c:1026:gst_omx_component_get_state:<omxh264dec-omxh264dec0> decoder returning state Loaded
0:00:00.560748205  2922      0xa4008f0 DEBUG                    omx gstomx.c:1158:gst_omx_component_set_parameter:<omxh264dec-omxh264dec0> Setting decoder parameter at index 0x02000001
[E] [SetParameter]: OMX_IndexParamPortDefinition : OMX_ErrorBadParameter
0:00:00.561201501  2922      0xa4008f0 ERROR                    omx gstomx.c:1161:gst_omx_component_set_parameter:<omxh264dec-omxh264dec0> Set decoder parameter at index 0x02000001: Bad parameter (0x80001005)
0:00:00.561255776  2922      0xa4008f0 DEBUG                    omx gstomx.c:1139:gst_omx_component_get_parameter:<omxh264dec-omxh264dec0> Getting decoder parameter at index 0x02000001
0:00:00.561292630  2922      0xa4008f0 DEBUG                    omx gstomx.c:1142:gst_omx_component_get_parameter:<omxh264dec-omxh264dec0> Got decoder parameter at index 0x02000001: None (0x00000000)
0:00:00.561349875  2922      0xa4008f0 ERROR                    omx gstomx.c:1340:gst_omx_port_update_port_definition:<omxh264dec-omxh264dec0> Updated decoder port 0 definition: Bad parameter (0x80001005)
0:00:00.561558426  2922      0xa4008f0 DEBUG                    omx gstomx.c:1139:gst_omx_component_get_parameter:<omxh264dec-omxh264dec0> Getting decoder parameter at index 0x02000001
0:00:00.561601221  2922      0xa4008f0 DEBUG                    omx gstomx.c:1142:gst_omx_component_get_parameter:<omxh264dec-omxh264dec0> Got decoder parameter at index 0x02000001: None (0x00000000)
0:00:00.561669347  2922      0xa4008f0 DEBUG                    omx gstomx.c:976:gst_omx_component_get_state:<omxh264dec-omxh264dec0> Getting state of decoder
0:00:00.561699290  2922      0xa4008f0 DEBUG                    omx gstomx.c:1026:gst_omx_component_get_state:<omxh264dec-omxh264dec0> decoder returning state Loaded
0:00:00.561730413  2922      0xa4008f0 DEBUG                    omx gstomx.c:1158:gst_omx_component_set_parameter:<omxh264dec-omxh264dec0> Setting decoder parameter at index 0x02000001
[E] [SetParameter]: OMX_IndexParamPortDefinition : OMX_ErrorBadParameter

Tags (3)
0 Kudos
11 Replies
Xilinx Employee
Xilinx Employee
1,051 Views
Registered: ‎08-01-2007

Re: Compatibility problem to decode some H264 stream encoded by imx6 encoder

It could be that the stream has an error in it.  We have been working to improve the error handling and you will see significant improvements in the 2018.3 release.  One good way to test this is to try decoding the stream with ffmpeg/ffplay.  it will tell you if it has run into any errors during decode and it was able to conceal the errors.

Additionally you can try using the example control software application documented in PG252 June 6. 2018 on page 107.

Chris
Video Design Hub | Embedded SW Support

---------------------------------------------------------------------------
Don’t forget to Reply, Kudo, and Accept as Solution.
---------------------------------------------------------------------------
Contributor
Contributor
1,014 Views
Registered: ‎09-05-2018

Re: Compatibility problem to decode some H264 stream encoded by imx6 encoder

ffplay an AL_Decoder are decoding the stream without any error. Whit xilinx it doesn't try to start just have problem at the beginning when gstreamer-omx plugin try to configure the Hardware to decode stream

my assumption is that

Profile : 66
Level : 31

is not supported in lib-omx coming from TRD 2018.2. Can you confirm?

 

 

[ezerbib@localhost Documents]$ ffplay "rtsp://192.168.68.181:554/stream"
ffplay version 4.0.2 Copyright (c) 2003-2018 the FFmpeg developers
built with gcc 8 (GCC)
configuration: --prefix=/usr --bindir=/usr/bin --datadir=/usr/share/ffmpeg --docdir=/usr/share/doc/ffmpeg --incdir=/usr/include/ffmpeg --libdir=/usr/lib64 --mandir=/usr/share/man --arch=x86_64 --optflags='-O2 -g -pipe -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -Wp,-D_GLIBCXX_ASSERTIONS -fexceptions -fstack-protector-strong -grecord-gcc-switches -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -specs=/usr/lib/rpm/redhat/redhat-annobin-cc1 -m64 -mtune=generic -fasynchronous-unwind-tables -fstack-clash-protection -fcf-protection' --extra-ldflags='-Wl,-z,relro -Wl,-z,now -specs=/usr/lib/rpm/redhat/redhat-hardened-ld ' --extra-cflags=' ' --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libvo-amrwbenc --enable-version3 --enable-bzlib --disable-crystalhd --enable-fontconfig --enable-frei0r --enable-gcrypt --enable-gnutls --enable-ladspa --enable-libass --enable-libbluray --enable-libcdio --enable-libdrm --enable-indev=jack --enable-libfreetype --enable-libfribidi --enable-libgsm --enable-libmp3lame --enable-nvenc --enable-openal --enable-opencl --enable-opengl --enable-libopenjpeg --enable-libopus --enable-libpulse --enable-librsvg --enable-libsoxr --enable-libspeex --enable-libtheora --enable-libvorbis --enable-libv4l2 --enable-libvidstab --enable-libvpx --enable-libx264 --enable-libx265 --enable-libxvid --enable-libzvbi --enable-avfilter --enable-avresample --enable-postproc --enable-pthreads --disable-static --enable-shared --enable-gpl --disable-debug --disable-stripping --shlibdir=/usr/lib64 --enable-libmfx --enable-runtime-cpudetect
libavutil 56. 14.100 / 56. 14.100
libavcodec 58. 18.100 / 58. 18.100
libavformat 58. 12.100 / 58. 12.100
libavdevice 58. 3.100 / 58. 3.100
libavfilter 7. 16.100 / 7. 16.100
libavresample 4. 0. 0 / 4. 0. 0
libswscale 5. 1.100 / 5. 1.100
libswresample 3. 1.100 / 3. 1.100
libpostproc 55. 1.100 / 55. 1.100
Input #0, rtsp, from 'rtsp://192.168.68.181:554/stream': 0B f=0/0
Metadata:
title : Session streamed with GStreamer
comment : rtsp-server
Duration: N/A, start: 341.326589, bitrate: N/A
Stream #0:0: Video: h264 (Constrained Baseline), yuv420p(progressive), 1920x1080, 30 fps, 30 tbr, 90k tbn, 180k tbc
345.36 M-V: 0.040 fd= 0 aq= 0KB vq= 86KB sq= 0B f=0/0
[ezerbib@localhost Documents]$

 


root@zcu106_vcu_trd:~# AL_Decoder.exe -avc -in /home/root/\'eric\'\[2018-10-08_09-03-53\]-00002.mp4 -out /media/card/o.yuv
Allegro DVT2 - AVC/HEVC Decoder Reference Software v1.0.40 - Copyright (C) 2018
Confidential material

Resolution : 1280x720
FourCC : NV12
Profile : 66
Level : 31
Buffer needed : 9 of size 1474560

Displayed picture #1960 - ^C

0 Kudos
Xilinx Employee
Xilinx Employee
986 Views
Registered: ‎08-01-2007

Re: Compatibility problem to decode some H264 stream encoded by imx6 encoder

@ericzerbibThanks for providing the profile information.  And for letting us know that ffplay did not have any problems decoding the stream.


@@@ericzerbib wrote:

ffplay an AL_Decoder are decoding the stream without any error. Whit xilinx it doesn't try to start just have problem at the beginning when gstreamer-omx plugin try to configure the Hardware to decode stream

my assumption is that

Profile : 66
Level : 31

is not supported in lib-omx coming from TRD 2018.2. Can you confirm?

The supported profiles and levels for the Zynq UltraScale+ MPSoC VCU are documented in PG252 in the features section starting on page 17 of PG252 v1.1 June 6, 2018.

Profile : 66 = Baseline, which is supported.
Level : 31 = 3.1 and we support up to Level 5.2, so this should be covered as well.

We have made some significant updates to the VCU Software to address many hangs and crashes.  So I'm going to recommend you test this stream in the upcoming 2018.3 release and see if that resolves the decoding problem.  Please watch https://www.xilinx.com for the release, or contact your local FAE for more details on when it will be available.

Chris
Video Design Hub | Embedded SW Support

---------------------------------------------------------------------------
Don’t forget to Reply, Kudo, and Accept as Solution.
---------------------------------------------------------------------------
0 Kudos
Contributor
Contributor
911 Views
Registered: ‎09-05-2018

Re: Compatibility problem to decode some H264 stream encoded by imx6 encoder

Thanks for your reply chrisar

I have downloaded the new 2018.3 SDK - And the problem is stiil here note that the profile is "contrainted-baseline"

caps = video/x-h264, stream-format=(string)byte-stream, alignment=(string)au, width=(int)1920, height=(int)1080, framerate=(fraction)0/1, interlace-mode=(string)progressive, chroma-format=(string)4:2:0, bit-depth-luma=(uint)8, bit-depth-chroma=(uint)8, parsed=(boolean)true, profile=(string)constrained-baseline, level=(string)4

somtething wrong in libomx but how can I debug the library code? using xsdk for example is it possible to have debug symbols enable in the libomx ?

Thanks in advance

 

Sample of Log session

 

root@zcu106_vcu_trd:/media/card# GST_DEBUG=3 gst-launch-1.0 -v --no-fault rtspsrc location=rtsp://192.168.0.72:554/stream latency=0 name=demux demux. ! rtph264depay ! h264parse ! queue max-size-buffers=0 max-size-bytes=5 ! omxh264dec internal-entropy-buffers=2 latency-mode=1 ! queue max-size-buffers=0 max-size-bytes=5 ! kmssink bus-id="a0070000.v_mix" max-lateness=20000000 plane-id=30 qos=true sync=false Setting pipeline to PAUSED ...
Pipeline is live and does not need PREROLL ...
/GstPipeline:pipeline0/GstKMSSink:kmssink0: display-width = 3840
/GstPipeline:pipeline0/GstKMSSink:kmssink0: display-height = 2160
Progress: (open) Opening Stream
Progress: (connect) Connecting to rtsp://192.168.0.72:554/stream
Progress: (open) Retrieving server options
Progress: (open) Retrieving media info
Progress: (request) SETUP stream 0
/GstPipeline:pipeline0/GstRTSPSrc:demux/GstRtpBin:manager: latency = 0
/GstPipeline:pipeline0/GstRTSPSrc:demux/GstRtpBin:manager: ntp-sync = false
/GstPipeline:pipeline0/GstRTSPSrc:demux/GstRtpBin:manager: rfc7273-sync = false
/GstPipeline:pipeline0/GstRTSPSrc:demux/GstRtpBin:manager: ntp-time-source = NTP time based on realtime clock
/GstPipeline:pipeline0/GstRTSPSrc:demux/GstRtpBin:manager: drop-on-latency = false
/GstPipeline:pipeline0/GstRTSPSrc:demux/GstRtpBin:manager: max-rtcp-rtp-time-diff = 1000
/GstPipeline:pipeline0/GstRTSPSrc:demux/GstRtpBin:manager: buffer-mode = Slave receiver to sender clock
/GstPipeline:pipeline0/GstRTSPSrc:demux/GstUDPSrc:udpsrc1: timeout = 5000000000
/GstPipeline:pipeline0/GstRTSPSrc:demux/GstUDPSrc:udpsrc1: caps = application/x-rtp, media=(string)video, payload=(int)96, clock-rate=(int)90000, encoding-name=(string)H264, packetization-mode=(string)1, sprop-parameter-sets=(string)"Z0JAKKaAeAIn5UAA\,aM48gAA\=", a-tool=(string)GStreamer, a-type=(string)broadcast, a-framerate=(string)30, a-ts-refclk=(string)local, a-mediaclk=(string)sender, ssrc=(uint)803597881
/GstPipeline:pipeline0/GstRTSPSrc:demux/GstUDPSrc:udpsrc2: caps = application/x-rtcp
Progress: (open) Opened Stream
Setting pipeline to PLAYING ...
New clock: GstSystemClock
/GstPipeline:pipeline0/GstRTSPSrc:demux/GstRtpBin:manager: buffer-mode = Slave receiver to sender clock
Progress: (request) Sending PLAY request
Progress: (request) Sending PLAY request
0:00:00.328956519 3166 0x7f90049c50 FIXME default gstutils.c:3902:gst_pad_create_stream_id_internal:<fakesrc0:src> Creating random stream-id, consider implementing a deterministic way of creating a stream-id
/GstPipeline:pipeline0/GstRTSPSrc:demux/GstUDPSrc:udpsrc1: caps = application/x-rtp, media=(string)video, payload=(int)96, clock-rate=(int)90000, encoding-name=(string)H264, packetization-mode=(string)1, sprop-parameter-sets=(string)"Z0JAKKaAeAIn5UAA\,aM48gAA\=", a-tool=(string)GStreamer, a-type=(string)broadcast, a-framerate=(string)30, a-ts-refclk=(string)local, a-mediaclk=(string)sender, ssrc=(uint)803597881, clock-base=(uint)2611053871, seqnum-base=(uint)36837, npt-start=(guint64)89187735719587, play-speed=(double)1, play-scale=(double)1
Progress: (request) Sent PLAY request
/GstPipeline:pipeline0/GstRTSPSrc:demux/GstUDPSrc:udpsrc1.GstPad:src: caps = application/x-rtp, media=(string)video, payload=(int)96, clock-rate=(int)90000, encoding-name=(string)H264, packetization-mode=(string)1, sprop-parameter-sets=(string)"Z0JAKKaAeAIn5UAA\,aM48gAA\=", a-tool=(string)GStreamer, a-type=(string)broadcast, a-framerate=(string)30, a-ts-refclk=(string)local, a-mediaclk=(string)sender, ssrc=(uint)803597881, clock-base=(uint)2611053871, seqnum-base=(uint)36837, npt-start=(guint64)89187735719587, play-speed=(double)1, play-scale=(double)1
/GstPipeline:pipeline0/GstRTSPSrc:demux/GstRtpBin:manager.GstGhostPad:recv_rtp_sink_0.GstProxyPad:proxypad0: caps = application/x-rtp, media=(string)video, payload=(int)96, clock-rate=(int)90000, encoding-name=(string)H264, packetization-mode=(string)1, sprop-parameter-sets=(string)"Z0JAKKaAeAIn5UAA\,aM48gAA\=", a-tool=(string)GStreamer, a-type=(string)broadcast, a-framerate=(string)30, a-ts-refclk=(string)local, a-mediaclk=(string)sender, ssrc=(uint)803597881, clock-base=(uint)2611053871, seqnum-base=(uint)36837, npt-start=(guint64)89187735719587, play-speed=(double)1, play-scale=(double)1
/GstPipeline:pipeline0/GstRTSPSrc:demux/GstRtpBin:manager.GstGhostPad:recv_rtp_sink_0.GstProxyPad:proxypad0: caps = application/x-rtp, media=(string)video, payload=(int)96, clock-rate=(int)90000, encoding-name=(string)H264, packetization-mode=(string)1, sprop-parameter-sets=(string)"Z0JAKKaAeAIn5UAA\,aM48gAA\=", a-tool=(string)GStreamer, a-type=(string)broadcast, a-framerate=(string)30, a-ts-refclk=(string)local, a-mediaclk=(string)sender, ssrc=(uint)803597881, clock-base=(uint)2611053871, seqnum-base=(uint)36837, npt-start=(guint64)89187735719587, play-speed=(double)1, play-scale=(double)1
/GstPipeline:pipeline0/GstRTSPSrc:demux/GstRtpBin:manager/GstFunnel:funnel0.GstFunnelPad:funnelpad0: caps = application/x-rtp, media=(string)video, payload=(int)96, clock-rate=(int)90000, encoding-name=(string)H264, packetization-mode=(string)1, sprop-parameter-sets=(string)"Z0JAKKaAeAIn5UAA\,aM48gAA\=", a-tool=(string)GStreamer, a-type=(string)broadcast, a-framerate=(string)30, a-ts-refclk=(string)local, a-mediaclk=(string)sender, ssrc=(uint)803597881, clock-base=(uint)2611053871, seqnum-base=(uint)36837, npt-start=(guint64)89187735719587, play-speed=(double)1, play-scale=(double)1
/GstPipeline:pipeline0/GstRTSPSrc:demux/GstRtpBin:manager.GstGhostPad:recv_rtp_sink_0: caps = application/x-rtp, media=(string)video, payload=(int)96, clock-rate=(int)90000, encoding-name=(string)H264, packetization-mode=(string)1, sprop-parameter-sets=(string)"Z0JAKKaAeAIn5UAA\,aM48gAA\=", a-tool=(string)GStreamer, a-type=(string)broadcast, a-framerate=(string)30, a-ts-refclk=(string)local, a-mediaclk=(string)sender, ssrc=(uint)803597881, clock-base=(uint)2611053871, seqnum-base=(uint)36837, npt-start=(guint64)89187735719587, play-speed=(double)1, play-scale=(double)1
/GstPipeline:pipeline0/GstRTSPSrc:demux/GstRtpBin:manager.GstGhostPad:recv_rtcp_sink_0.GstProxyPad:proxypad1: caps = application/x-rtcp
/GstPipeline:pipeline0/GstRTSPSrc:demux/GstRtpBin:manager/GstFunnel:funnel1.GstFunnelPad:funnelpad1: caps = application/x-rtcp
/GstPipeline:pipeline0/GstRTSPSrc:demux/GstRtpBin:manager.GstGhostPad:recv_rtcp_sink_0: caps = application/x-rtcp
/GstPipeline:pipeline0/GstRTSPSrc:demux/GstUDPSrc:udpsrc1: timeout = 0
/GstPipeline:pipeline0/GstRTSPSrc:demux/GstRtpBin:manager/GstFunnel:funnel0.GstPad:src: caps = application/x-rtp, media=(string)video, payload=(int)96, clock-rate=(int)90000, encoding-name=(string)H264, packetization-mode=(string)1, sprop-parameter-sets=(string)"Z0JAKKaAeAIn5UAA\,aM48gAA\=", a-tool=(string)GStreamer, a-type=(string)broadcast, a-framerate=(string)30, a-ts-refclk=(string)local, a-mediaclk=(string)sender, ssrc=(uint)803597881, clock-base=(uint)2611053871, seqnum-base=(uint)36837, npt-start=(guint64)89187735719587, play-speed=(double)1, play-scale=(double)1
/GstPipeline:pipeline0/GstRTSPSrc:demux/GstRtpBin:manager/GstRtpSession:rtpsession0.GstPad:recv_rtp_src: caps = application/x-rtp, media=(string)video, payload=(int)96, clock-rate=(int)90000, encoding-name=(string)H264, packetization-mode=(string)1, sprop-parameter-sets=(string)"Z0JAKKaAeAIn5UAA\,aM48gAA\=", a-tool=(string)GStreamer, a-type=(string)broadcast, a-framerate=(string)30, a-ts-refclk=(string)local, a-mediaclk=(string)sender, ssrc=(uint)803597881, clock-base=(uint)2611053871, seqnum-base=(uint)36837, npt-start=(guint64)89187735719587, play-speed=(double)1, play-scale=(double)1
/GstPipeline:pipeline0/GstRTSPSrc:demux/GstRtpBin:manager/GstRtpSsrcDemux:rtpssrcdemux0.GstPad:sink: caps = application/x-rtp, media=(string)video, payload=(int)96, clock-rate=(int)90000, encoding-name=(string)H264, packetization-mode=(string)1, sprop-parameter-sets=(string)"Z0JAKKaAeAIn5UAA\,aM48gAA\=", a-tool=(string)GStreamer, a-type=(string)broadcast, a-framerate=(string)30, a-ts-refclk=(string)local, a-mediaclk=(string)sender, ssrc=(uint)803597881, clock-base=(uint)2611053871, seqnum-base=(uint)36837, npt-start=(guint64)89187735719587, play-speed=(double)1, play-scale=(double)1
/GstPipeline:pipeline0/GstRTSPSrc:demux/GstRtpBin:manager/GstRtpSession:rtpsession0.GstPad:recv_rtp_sink: caps = application/x-rtp, media=(string)video, payload=(int)96, clock-rate=(int)90000, encoding-name=(string)H264, packetization-mode=(string)1, sprop-parameter-sets=(string)"Z0JAKKaAeAIn5UAA\,aM48gAA\=", a-tool=(string)GStreamer, a-type=(string)broadcast, a-framerate=(string)30, a-ts-refclk=(string)local, a-mediaclk=(string)sender, ssrc=(uint)803597881, clock-base=(uint)2611053871, seqnum-base=(uint)36837, npt-start=(guint64)89187735719587, play-speed=(double)1, play-scale=(double)1
0:00:00.361998570 3166 0x7f90049d40 FIXME rtpjitterbuffer gstrtpjitterbuffer.c:1488:gst_jitter_buffer_sink_parse_caps:<rtpjitterbuffer0> Unsupported timestamp reference clock
0:00:00.362041405 3166 0x7f90049d40 FIXME rtpjitterbuffer gstrtpjitterbuffer.c:1496:gst_jitter_buffer_sink_parse_caps:<rtpjitterbuffer0> Unsupported media clock
/GstPipeline:pipeline0/GstRTSPSrc:demux/GstRtpBin:manager/GstRtpJitterBuffer:rtpjitterbuffer0.GstPad:sink: caps = application/x-rtp, media=(string)video, payload=(int)96, clock-rate=(int)90000, encoding-name=(string)H264, packetization-mode=(string)1, sprop-parameter-sets=(string)"Z0JAKKaAeAIn5UAA\,aM48gAA\=", a-tool=(string)GStreamer, a-type=(string)broadcast, a-framerate=(string)30, a-ts-refclk=(string)local, a-mediaclk=(string)sender, ssrc=(uint)803597881, clock-base=(uint)2611053871, seqnum-base=(uint)36837, npt-start=(guint64)89187735719587, play-speed=(double)1, play-scale=(double)1
/GstPipeline:pipeline0/GstRTSPSrc:demux/GstRtpBin:manager/GstRtpJitterBuffer:rtpjitterbuffer0.GstPad:sink: caps = application/x-rtp, media=(string)video, payload=(int)96, clock-rate=(int)90000, encoding-name=(string)H264, packetization-mode=(string)1, sprop-parameter-sets=(string)"Z0JAKKaAeAIn5UAA\,aM48gAA\=", a-tool=(string)GStreamer, a-type=(string)broadcast, a-framerate=(string)30, a-ts-refclk=(string)local, a-mediaclk=(string)sender, ssrc=(uint)803597881, clock-base=(uint)2611053871, seqnum-base=(uint)36837, npt-start=(guint64)89187735719587, play-speed=(double)1, play-scale=(double)1
/GstPipeline:pipeline0/GstRTSPSrc:demux/GstRtpBin:manager/GstRtpPtDemux:rtpptdemux0.GstPad:sink: caps = application/x-rtp, media=(string)video, payload=(int)96, clock-rate=(int)90000, encoding-name=(string)H264, packetization-mode=(string)1, sprop-parameter-sets=(string)"Z0JAKKaAeAIn5UAA\,aM48gAA\=", a-tool=(string)GStreamer, a-type=(string)broadcast, a-framerate=(string)30, a-ts-refclk=(string)local, a-mediaclk=(string)sender, ssrc=(uint)803597881, clock-base=(uint)2611053871, seqnum-base=(uint)36837, npt-start=(guint64)89187735719587, play-speed=(double)1, play-scale=(double)1
/GstPipeline:pipeline0/GstRtpH264Depay:rtph264depay0.GstPad:src: caps = video/x-h264, stream-format=(string)byte-stream, alignment=(string)au
/GstPipeline:pipeline0/GstH264Parse:h264parse0.GstPad:src: caps = video/x-h264, stream-format=(string)byte-stream, alignment=(string)au, parsed=(boolean)true
/GstPipeline:pipeline0/GstH264Parse:h264parse0.GstPad:sink: caps = video/x-h264, stream-format=(string)byte-stream, alignment=(string)au
/GstPipeline:pipeline0/GstRtpH264Depay:rtph264depay0.GstPad:sink: caps = application/x-rtp, media=(string)video, payload=(int)96, clock-rate=(int)90000, encoding-name=(string)H264, packetization-mode=(string)1, sprop-parameter-sets=(string)"Z0JAKKaAeAIn5UAA\,aM48gAA\=", a-tool=(string)GStreamer, a-type=(string)broadcast, a-framerate=(string)30, a-ts-refclk=(string)local, a-mediaclk=(string)sender, ssrc=(uint)803597881, clock-base=(uint)2611053871, seqnum-base=(uint)36837, npt-start=(guint64)89187735719587, play-speed=(double)1, play-scale=(double)1
/GstPipeline:pipeline0/GstRTSPSrc:demux.GstGhostPad:recv_rtp_src_0_803597881_96.GstProxyPad:proxypad4: caps = application/x-rtp, media=(string)video, payload=(int)96, clock-rate=(int)90000, encoding-name=(string)H264, packetization-mode=(string)1, sprop-parameter-sets=(string)"Z0JAKKaAeAIn5UAA\,aM48gAA\=", a-tool=(string)GStreamer, a-type=(string)broadcast, a-framerate=(string)30, a-ts-refclk=(string)local, a-mediaclk=(string)sender, ssrc=(uint)803597881, clock-base=(uint)2611053871, seqnum-base=(uint)36837, npt-start=(guint64)89187735719587, play-speed=(double)1, play-scale=(double)1
/GstPipeline:pipeline0/GstRTSPSrc:demux/GstRtpBin:manager.GstGhostPad:recv_rtp_src_0_803597881_96.GstProxyPad:proxypad3: caps = application/x-rtp, media=(string)video, payload=(int)96, clock-rate=(int)90000, encoding-name=(string)H264, packetization-mode=(string)1, sprop-parameter-sets=(string)"Z0JAKKaAeAIn5UAA\,aM48gAA\=", a-tool=(string)GStreamer, a-type=(string)broadcast, a-framerate=(string)30, a-ts-refclk=(string)local, a-mediaclk=(string)sender, ssrc=(uint)803597881, clock-base=(uint)2611053871, seqnum-base=(uint)36837, npt-start=(guint64)89187735719587, play-speed=(double)1, play-scale=(double)1
/GstPipeline:pipeline0/GstH264Parse:h264parse0.GstPad:src: caps = video/x-h264, stream-format=(string)byte-stream, alignment=(string)au, width=(int)1920, height=(int)1080, framerate=(fraction)0/1, interlace-mode=(string)progressive, chroma-format=(string)4:2:0, bit-depth-luma=(uint)8, bit-depth-chroma=(uint)8, parsed=(boolean)true, profile=(string)constrained-baseline, level=(string)4
/GstPipeline:pipeline0/GstQueue:queue0.GstPad:sink: caps = video/x-h264, stream-format=(string)byte-stream, alignment=(string)au, width=(int)1920, height=(int)1080, framerate=(fraction)0/1, interlace-mode=(string)progressive, chroma-format=(string)4:2:0, bit-depth-luma=(uint)8, bit-depth-chroma=(uint)8, parsed=(boolean)true, profile=(string)constrained-baseline, level=(string)4
/GstPipeline:pipeline0/GstQueue:queue0.GstPad:sink: caps = video/x-h264, stream-format=(string)byte-stream, alignment=(string)au, width=(int)1920, height=(int)1080, framerate=(fraction)0/1, interlace-mode=(string)progressive, chroma-format=(string)4:2:0, bit-depth-luma=(uint)8, bit-depth-chroma=(uint)8, parsed=(boolean)true, profile=(string)constrained-baseline, level=(string)4
[E] [SetParameter]: OMX_IndexParamPortDefinition : OMX_ErrorBadParameter
0:00:00.366424873 3166 0x29933f70 ERROR omx gstomx.c:1398:gst_omx_component_set_parameter:<omxh264dec-omxh264dec0> Set decoder parameter at index 0x02000001: Bad parameter (0x80001005)
0:00:00.366486959 3166 0x29933f70 ERROR omx gstomx.c:1577:gst_omx_port_update_port_definition:<omxh264dec-omxh264dec0> Updated decoder port 0 definition: Bad parameter (0x80001005)
0:00:00.366531523 3166 0x29933f70 WARN videodecoder gstvideodecoder.c:729:gst_video_decoder_setcaps:<omxh264dec-omxh264dec0> Subclass refused caps
[E] [SetParameter]: OMX_IndexParamPortDefinition : OMX_ErrorBadParameter
0:00:00.366709001 3166 0x29933f70 ERROR omx gstomx.c:1398:gst_omx_component_set_parameter:<omxh264dec-omxh264dec0> Set decoder parameter at index 0x02000001: Bad parameter (0x80001005)
0:00:00.366755496 3166 0x29933f70 ERROR omx gstomx.c:1577:gst_omx_port_update_port_definition:<omxh264dec-omxh264dec0> Updated decoder port 0 definition: Bad parameter (0x80001005)
0:00:00.366792279 3166 0x29933f70 WARN videodecoder gstvideodecoder.c:729:gst_video_decoder_setcaps:<omxh264dec-omxh264dec0> Subclass refused caps
[E] [SetParameter]: OMX_IndexParamPortDefinition : OMX_ErrorBadParameter
0:00:00.366944915 3166 0x29933f70 ERROR omx gstomx.c:1398:gst_omx_component_set_parameter:<omxh264dec-omxh264dec0> Set decoder parameter at index 0x02000001: Bad parameter (0x80001005)
0:00:00.366991079 3166 0x29933f70 ERROR omx gstomx.c:1577:gst_omx_port_update_port_definition:<omxh264dec-omxh264dec0> Updated decoder port 0 definition: Bad parameter (0x80001005)
0:00:00.367025023 3166 0x29933f70 WARN videodecoder gstvideodecoder.c:729:gst_video_decoder_setcaps:<omxh264dec-omxh264dec0> Subclass refused caps
[E] [SetParameter]: OMX_IndexParamPortDefinition : OMX_ErrorBadParameter
0:00:00.367173687 3166 0x29933f70 ERROR omx gstomx.c:1398:gst_omx_component_set_parameter:<omxh264dec-omxh264dec0> Set decoder parameter at index 0x02000001: Bad parameter (0x80001005)
0:00:00.367224443 3166 0x29933f70 ERROR omx gstomx.c:1577:gst_omx_port_update_port_definition:<omxh264dec-omxh264dec0> Updated decoder port 0 definition: Bad parameter (0x80001005)
0:00:00.367258566 3166 0x29933f70 WARN videodecoder gstvideodecoder.c:729:gst_video_decoder_setcaps:<omxh264dec-omxh264dec0> Subclass refused caps
0:00:00.426444320 3166 0x7f90049d40 WARN basesrc gstbasesrc.c:2939:gst_base_src_loop:<udpsrc1> error: Internal data stream error.
0:00:00.426477383 3166 0x7f90049d40 WARN basesrc gstbasesrc.c:2939:gst_base_src_loop:<udpsrc1> error: streaming stopped, reason not-negotiated (-4)
ERROR: from element /GstPipeline:pipeline0/GstRTSPSrc:demux/GstUDPSrc:udpsrc1: Internal data stream error.
Additional debug info:
../../../../gstreamer-1.12.2/libs/gst/base/gstbasesrc.c(2939): gst_base_src_loop (): /GstPipeline:pipeline0/GstRTSPSrc:demux/GstUDPSrc:udpsrc1:
streaming stopped, reason not-negotiated (-4)
Execution ended after 0:00:00.098770889
Setting pipeline to PAUSED ...
Setting pipeline to READY ...
0:00:00.427733868 3166 0x299340f0 WARN rtspsrc gstrtspsrc.c:5466:gst_rtspsrc_try_send:<demux> receive interrupted
0:00:00.427771712 3166 0x299340f0 WARN rtspsrc gstrtspsrc.c:7519:gst_rtspsrc_pause:<demux> PAUSE interrupted
Setting pipeline to NULL ...
Freeing pipeline ...

0 Kudos
Moderator
Moderator
905 Views
Registered: ‎11-09-2015

Re: Compatibility problem to decode some H264 stream encoded by imx6 encoder

Hi @ericzerbib,

Could you try with the VCU TRD 2018.3 for this issue as well and let us know your results?

Thanks and Regards,


Florent
Product Application Engineer - Xilinx Technical Support EMEA
**~ Don't forget to reply, give kudos, and accept as solution.~**
0 Kudos
Xilinx Employee
Xilinx Employee
895 Views
Registered: ‎08-01-2007

Re: Compatibility problem to decode some H264 stream encoded by imx6 encoder

In addition to testing in 2018.3, I also recommend that you apply the 2018.3 patches in AR71798.

Chris
Video Design Hub | Embedded SW Support

---------------------------------------------------------------------------
Don’t forget to Reply, Kudo, and Accept as Solution.
---------------------------------------------------------------------------
Contributor
Contributor
875 Views
Registered: ‎09-05-2018

Re: Compatibility problem to decode some H264 stream encoded by imx6 encoder

Will test today and send a report to you.

0 Kudos
Contributor
Contributor
864 Views
Registered: ‎09-05-2018

Re: Compatibility problem to decode some H264 stream encoded by imx6 encoder

Unfortunately applying this patch to 2018.3 ( even after using "petalinux-build -x mrproper" ) result in error

[ezerbib@krnd4 zcu106-vcu-trd-2018-3]$ petalinux-build
[INFO] building project
[INFO] sourcing bitbake
INFO: bitbake petalinux-user-image
Loading cache: 100% |#################################################################################################################################################################################################################################| Time: 0:00:00
Loaded 3463 entries from dependency cache.
Parsing recipes: 100% |###############################################################################################################################################################################################################################| Time: 0:00:04
Parsing of 2572 .bb files complete (2538 cached, 34 parsed). 3464 targets, 137 skipped, 0 masked, 0 errors.
NOTE: Resolving any missing task queue dependencies
Initialising tasks: 100% |############################################################################################################################################################################################################################| Time: 0:00:22
Checking sstate mirror object availability: 100% |####################################################################################################################################################################################################| Time: 0:00:05
NOTE: Executing SetScene Tasks
NOTE: Executing RunQueue Tasks
ERROR: gstreamer1.0-1.12.2-r0 do_compile: oe_runmake failed
ERROR: gstreamer1.0-1.12.2-r0 do_compile: Function failed: do_compile (log file is located at /home/ezerbib/work/xilinx/rdf0428-zcu106-vcu-trd-2018-3/myimage/zcu106-vcu-trd-2018-3/build/tmp/work/aarch64-xilinx-linux/gstreamer1.0/1.12.2-r0/temp/log.do_compile.25575)
ERROR: Logfile of failure stored in: /home/ezerbib/work/xilinx/rdf0428-zcu106-vcu-trd-2018-3/myimage/zcu106-vcu-trd-2018-3/build/tmp/work/aarch64-xilinx-linux/gstreamer1.0/1.12.2-r0/temp/log.do_compile.25575
Log data follows:
| DEBUG: SITE files ['endian-little', 'bit-64', 'arm-common', 'arm-64', 'common-linux', 'common-glibc', 'aarch64-linux', 'common']
| DEBUG: Executing shell function do_compile
| NOTE: make -j 24
| make all-recursive
| make[1]: Entering directory '/home/ezerbib/work/xilinx/rdf0428-zcu106-vcu-trd-2018-3/myimage/zcu106-vcu-trd-2018-3/build/tmp/work/aarch64-xilinx-linux/gstreamer1.0/1.12.2-r0/build'
| Making all in pkgconfig
| make[2]: Entering directory '/home/ezerbib/work/xilinx/rdf0428-zcu106-vcu-trd-2018-3/myimage/zcu106-vcu-trd-2018-3/build/tmp/work/aarch64-xilinx-linux/gstreamer1.0/1.12.2-r0/build/pkgconfig'
| make[2]: Nothing to be done for 'all'.
| make[2]: Leaving directory '/home/ezerbib/work/xilinx/rdf0428-zcu106-vcu-trd-2018-3/myimage/zcu106-vcu-trd-2018-3/build/tmp/work/aarch64-xilinx-linux/gstreamer1.0/1.12.2-r0/build/pkgconfig'
| Making all in gst
| make[2]: Entering directory '/home/ezerbib/work/xilinx/rdf0428-zcu106-vcu-trd-2018-3/myimage/zcu106-vcu-trd-2018-3/build/tmp/work/aarch64-xilinx-linux/gstreamer1.0/1.12.2-r0/build/gst'
| make all-recursive
| make[3]: Entering directory '/home/ezerbib/work/xilinx/rdf0428-zcu106-vcu-trd-2018-3/myimage/zcu106-vcu-trd-2018-3/build/tmp/work/aarch64-xilinx-linux/gstreamer1.0/1.12.2-r0/build/gst'
| Making all in parse
| make[4]: Entering directory '/home/ezerbib/work/xilinx/rdf0428-zcu106-vcu-trd-2018-3/myimage/zcu106-vcu-trd-2018-3/build/tmp/work/aarch64-xilinx-linux/gstreamer1.0/1.12.2-r0/build/gst/parse'
| make[4]: Nothing to be done for 'all'.
| make[4]: Leaving directory '/home/ezerbib/work/xilinx/rdf0428-zcu106-vcu-trd-2018-3/myimage/zcu106-vcu-trd-2018-3/build/tmp/work/aarch64-xilinx-linux/gstreamer1.0/1.12.2-r0/build/gst/parse'
| Making all in printf
| make[4]: Entering directory '/home/ezerbib/work/xilinx/rdf0428-zcu106-vcu-trd-2018-3/myimage/zcu106-vcu-trd-2018-3/build/tmp/work/aarch64-xilinx-linux/gstreamer1.0/1.12.2-r0/build/gst/printf'
| make[4]: Nothing to be done for 'all'.
| make[4]: Leaving directory '/home/ezerbib/work/xilinx/rdf0428-zcu106-vcu-trd-2018-3/myimage/zcu106-vcu-trd-2018-3/build/tmp/work/aarch64-xilinx-linux/gstreamer1.0/1.12.2-r0/build/gst/printf'
| make[4]: Entering directory '/home/ezerbib/work/xilinx/rdf0428-zcu106-vcu-trd-2018-3/myimage/zcu106-vcu-trd-2018-3/build/tmp/work/aarch64-xilinx-linux/gstreamer1.0/1.12.2-r0/build/gst'
| make[4]: *** No rule to make target '/usr/bin/g-ir-scanner-wrapper', needed by 'Gst-1.0.gir'. Stop.
| make[4]: Leaving directory '/home/ezerbib/work/xilinx/rdf0428-zcu106-vcu-trd-2018-3/myimage/zcu106-vcu-trd-2018-3/build/tmp/work/aarch64-xilinx-linux/gstreamer1.0/1.12.2-r0/build/gst'
| make[3]: *** [Makefile:1685: all-recursive] Error 1
| make[3]: Leaving directory '/home/ezerbib/work/xilinx/rdf0428-zcu106-vcu-trd-2018-3/myimage/zcu106-vcu-trd-2018-3/build/tmp/work/aarch64-xilinx-linux/gstreamer1.0/1.12.2-r0/build/gst'
| make[2]: *** [Makefile:897: all] Error 2
| make[2]: Leaving directory '/home/ezerbib/work/xilinx/rdf0428-zcu106-vcu-trd-2018-3/myimage/zcu106-vcu-trd-2018-3/build/tmp/work/aarch64-xilinx-linux/gstreamer1.0/1.12.2-r0/build/gst'
| make[1]: *** [Makefile:730: all-recursive] Error 1
| make[1]: Leaving directory '/home/ezerbib/work/xilinx/rdf0428-zcu106-vcu-trd-2018-3/myimage/zcu106-vcu-trd-2018-3/build/tmp/work/aarch64-xilinx-linux/gstreamer1.0/1.12.2-r0/build'
| make: *** [Makefile:636: all] Error 2
| ERROR: oe_runmake failed
| WARNING: /home/ezerbib/work/xilinx/rdf0428-zcu106-vcu-trd-2018-3/myimage/zcu106-vcu-trd-2018-3/build/tmp/work/aarch64-xilinx-linux/gstreamer1.0/1.12.2-r0/temp/run.do_compile.25575:1 exit 1 from 'exit 1'
| ERROR: Function failed: do_compile (log file is located at /home/ezerbib/work/xilinx/rdf0428-zcu106-vcu-trd-2018-3/myimage/zcu106-vcu-trd-2018-3/build/tmp/work/aarch64-xilinx-linux/gstreamer1.0/1.12.2-r0/temp/log.do_compile.25575)
ERROR: Task (/home/ezerbib/work/xilinx/petalinux_v2018_3/components/yocto/source/aarch64/layers/core/meta/recipes-multimedia/gstreamer/gstreamer1.0_1.12.2.bb:do_compile) failed with exit code '1'

 

0 Kudos
Moderator
Moderator
752 Views
Registered: ‎11-09-2015

Re: Compatibility problem to decode some H264 stream encoded by imx6 encoder

Hi @ericzerbib,

Could you try to clean the Petalinux build and try to compile again?

Best Regards,


Florent
Product Application Engineer - Xilinx Technical Support EMEA
**~ Don't forget to reply, give kudos, and accept as solution.~**
0 Kudos
Moderator
Moderator
669 Views
Registered: ‎11-09-2015

Re: Compatibility problem to decode some H264 stream encoded by imx6 encoder

Hi @ericzerbib,

Do you have any updates on this?

If your question is answered or your issue is solved, please kindly mark the response which helped as solution (click on "Accept as solution" button below the reply)

If this is not solved/answered, please reply in the topic giving more information on your current status.

Thanks and Regards,


Florent
Product Application Engineer - Xilinx Technical Support EMEA
**~ Don't forget to reply, give kudos, and accept as solution.~**
0 Kudos
Contributor
Contributor
557 Views
Registered: ‎09-05-2018

Re: Compatibility problem to decode some H264 stream encoded by imx6 encoder

Unfortunately even when cleaning and applying this patch to 2018.3 ( even after using "petalinux-build -x mrproper" ) result in compilation error
0 Kudos