UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Observer furball
Observer
1,177 Views
Registered: ‎06-22-2017

Displayport TX SS v2.1 - HPD from the external monitor is not reflected in TX reg (0x130)

Jump to solution

Hi,

 

I build a design with DP tx subsystem and found register 0x130 can't reflect correct status of HPD in SDK.

 (the base address I set was 0x44A1_0000 and HDF map the same)

 

But when I change the base address to 0x44A8_0000 (according to example design),

the register works fine.

 

Why do I have to fix this base address? 

please help, thanks

0 Kudos
1 Solution

Accepted Solutions
Xilinx Employee
Xilinx Employee
1,468 Views
Registered: ‎05-07-2015

Re: Displayport TX SS v2.1 - HPD from the external monitor is not reflected in TX reg (0x130)

Jump to solution

Hi @furball

I have tested the DP  passthrough design  on KC705  twice with two different base addresses for DP TX and it worked fine both the times

I have specifically checked the HPD status bit too (as you can see in the attached  file). in this case DP TX base addres: 0X44A22000.

So I am sure there is some thing wrong at your end. I request you try again and  you can proceed with the default base address that is working fine with you if that is not an issue.

Thanks
Bharath
--------------------------------------------------​--------------------------------------------
Please mark the Answer as "Accept as solution" if information provided addresses your query/concern.
Give Kudos to a post which you think is helpful.
--------------------------------------------------​-------------------------------------------
HPD_reg_read.JPG
5 Replies
Moderator
Moderator
1,151 Views
Registered: ‎11-09-2015

Re: Displayport TX SS v2.1 - HPD from the external monitor is not reflected in TX reg (0x130)

Jump to solution

Hi @furball,

 

This is weird...

 

Could you tell me which vivado version you are using and if the example design you are talking about is the one integrated in vivado? (From what I remember you are using 2017.3 and the example design, correct?)

 

Did you try to only change the base address in the example design and see if the behaviour was still the same?

Did you correctly updated the hdf file in SDK? Are you sure you are using the correct bitstream?

 

Regards,

 

Florent

 

 


Florent
Product Application Engineer - Xilinx Technical Support EMEA
**~ Don't forget to reply, give kudos, and accept as solution.~**
0 Kudos
Observer furball
Observer
1,136 Views
Registered: ‎06-22-2017

Re: Displayport TX SS v2.1 - HPD from the external monitor is not reflected in TX reg (0x130)

Jump to solution

Hi @florentw,

 

 

Could you tell me which vivado version you are using and if the example design you are talking about is the one integrated in vivado? (From what I remember you are using 2017.3 and the example design, correct?)

---> Yes, I'm using vivado 2017.3. The example design sets the base address at 0x44A8_0000 and it works fine

 

 

Did you try to only change the base address in the example design and see if the behaviour was still the same?

--> I test my own design (DP tx & pattern gen) with vivado 2017.3, the HPD didn't reflect correctly when I set base address to 0x44A1_0000 , but it worked after I only change the base address to 0x44A8_0000.

 

 

Did you correctly updated the hdf file in SDK? Are you sure you are using the correct bitstream?

--> I've checked the hdf and all of the address are match, and Yes I use the correct bitstream

0 Kudos
Moderator
Moderator
1,084 Views
Registered: ‎10-04-2017

Re: Displayport TX SS v2.1 - HPD from the external monitor is not reflected in TX reg (0x130)

Jump to solution

Hi @furball,

 

Q1. In your design, is only 1 register incorrect or are all of the registers incorrect for the modified address?

 

Q2. In your design do you have an AXI Interconnect or SmartConnect?

        Q2A. If you do have either of these, in the implemented design can you see how large the AXI Address bus is that is connected to the DP IP?

 

Q3. Can you post both address maps for your design?

 

Regards,

Sam

Don't forget to reply, kudo, and accept as solution.

Xilinx Video Design Hub
0 Kudos
Moderator
Moderator
1,016 Views
Registered: ‎11-09-2015

Re: Displayport TX SS v2.1 - HPD from the external monitor is not reflected in TX reg (0x130)

Jump to solution

Hi @furball,

 

Do you have any update on this?

 

Regards,


Florent
Product Application Engineer - Xilinx Technical Support EMEA
**~ Don't forget to reply, give kudos, and accept as solution.~**
0 Kudos
Xilinx Employee
Xilinx Employee
1,469 Views
Registered: ‎05-07-2015

Re: Displayport TX SS v2.1 - HPD from the external monitor is not reflected in TX reg (0x130)

Jump to solution

Hi @furball

I have tested the DP  passthrough design  on KC705  twice with two different base addresses for DP TX and it worked fine both the times

I have specifically checked the HPD status bit too (as you can see in the attached  file). in this case DP TX base addres: 0X44A22000.

So I am sure there is some thing wrong at your end. I request you try again and  you can proceed with the default base address that is working fine with you if that is not an issue.

Thanks
Bharath
--------------------------------------------------​--------------------------------------------
Please mark the Answer as "Accept as solution" if information provided addresses your query/concern.
Give Kudos to a post which you think is helpful.
--------------------------------------------------​-------------------------------------------
HPD_reg_read.JPG