UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Observer blake_ding
Observer
1,499 Views
Registered: ‎09-04-2018

HDMI not work on zcu102 with TRD 2018.2

Jump to solution

Hi Sir,

I tried to verify the HDMI Tx/Rx on zcu102 with the default SD image of TRD 18.2, but I met following symptom :
It has a big chance to show "/etc/trd/trd-utils.sh: line 8: [: =: unary operator expected ERROR: No display device found" in the end of boot up message.
There was no device node of /sys/class/drm/card1-HDMI-A
And the boot up log as the attached file - zcu102_18_2_bootup_log2
The logs shows :
[ 11.771413] si5324 3-0068: unable to read from reg04
[ 11.779870] si5324 3-0068: unable to read from reg03
[ 11.789736] si5324 3-0068: unable to read from reg00
[ 11.798023] si5324 3-0068: unable to read from reg03
[ 11.803328] si5324 3-0068: unable to read from reg04
[ 11.809700] si5324 3-0068: unable to read from reg0b
[ 11.815133] si5324 3-0068: unable to read from reg15
[ 11.820646] si5324 3-0068: si5324 probe successful
[ 11.825622] si5324 13-0069: si5328 probed
[ 11.830493] xlnx-drm-hdmi a0080000.hdmi_txss: probed
[ 11.835724] xlnx-drm-hdmi a0080000.hdmi_txss: retimer-clk not ready -EPROBE_DEFER
[ 11.872626] [drm] Cannot find any crtc or sizes
[ 11.892150] si5324 13-0069: si5328 probe successful
[ 11.898193] xlnx-drm-hdmi a0080000.hdmi_txss: probed
[ 11.903412] xlnx-drm-hdmi a0080000.hdmi_txss: retimer-clk not ready -EPROBE_DEFER

But it has a little chance that I can get different message as the attached file - zcu102_18_2_bootup_log1
I can find the device node of /sys/class/drm/card1-HDMI-A is existed.
I can also query the status (connect/disconnect) of HDMI output when I plug in/out hdmi cable from monitor.
But even so, the application "run_video.sh" couldn't run well; the detailed info. as the log.

Thanks


BR
Blake

0 Kudos
1 Solution

Accepted Solutions
Moderator
Moderator
1,323 Views
Registered: ‎04-12-2017

Re: HDMI not work on zcu102 with TRD 2018.2

Jump to solution

Hello @blake_ding

 

You can order it for free.

try following answer record it has link to order power dongle

https://www.xilinx.com/support/answers/62629.html

Thank you

-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
6 Replies
Xilinx Employee
Xilinx Employee
1,412 Views
Registered: ‎08-02-2007

Re: HDMI not work on zcu102 with TRD 2018.2

Jump to solution

Hi @blake_ding

Which TRD are you using? From the log1 file, HDMI RX isn't initialized, and the design seems to expect DisplayPort monitor.

Can you type "modetest -M xlnx ", and see which connector is expected, DP or HDMI?

If you only want to uses HDMI RX and TX, please use HDMI Frame Buffer Example design : https://xilinx-wiki.atlassian.net/wiki/spaces/A/pages/18842083/HDMI+FrameBuffer+Example+Design+2018.1

 

0 Kudos
Observer blake_ding
Observer
1,381 Views
Registered: ‎09-04-2018

Re: HDMI not work on zcu102 with TRD 2018.2

Jump to solution

Hi Xud,

Thanks for your reply, my reply as below :
1. I use the SD image of Zynq UltraScale MPSoC Base TRD 2018.2 - Design Module 10
2. The result of "modetest -M xlnx " as attached file - modetest_log.txt
3. I also tried the project as you mentioned - HDMI FrameBuffer Example Design 2018.1, but it still not worked.
The log as file - zcu102_framebuffer.txt

BTW, someone said he has the same log and the led DS4 doesn't lit; he suggested the solution as https://www.xilinx.com/support/answers/66811.html
Is this reprogramming flow safe?

BR
Blake

0 Kudos
Xilinx Employee
Xilinx Employee
1,355 Views
Registered: ‎08-02-2007

Re: HDMI not work on zcu102 with TRD 2018.2

Jump to solution

@blake_ding

DS4 indicates a power issue, you need to follow the AR to re-program the power controller.

From modetest_log.txt, it indicates that connector uses Displayport, not HDMI

zcu102_framebuffer.txt shows there is some problem with onboard re-timer DP159, probably this is caused by power issue as well.

0 Kudos
Observer blake_ding
Observer
1,336 Views
Registered: ‎09-04-2018

Re: HDMI not work on zcu102 with TRD 2018.2

Jump to solution

Hi Xud,

Refer to AR#66811, according to page 5 of ZCU102_Power_Controllers_Reprogramming_Steps.pdf.
It shows we need a external dongle - MAXPOWERTOOL USB-to-PMBus interface dongle.
If this is a known issue, should we need to buy this dongle additionally?

For the result of modetest, although it shows the expected output is Displayport instead of HDMI out.
But as I mentioned in the case, it has a small chance to get device node of /sys/class/drm/card1-HDMI-A-1.
In this case, the board could detect the HDMI output port that connect or disconnect.

Does it possible cause by power issue? The DP159 or SI5324 didn't work well.
Thanks.

BR
Blake

0 Kudos
Moderator
Moderator
1,324 Views
Registered: ‎04-12-2017

Re: HDMI not work on zcu102 with TRD 2018.2

Jump to solution

Hello @blake_ding

 

You can order it for free.

try following answer record it has link to order power dongle

https://www.xilinx.com/support/answers/62629.html

Thank you

-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
Observer blake_ding
Observer
1,274 Views
Registered: ‎09-04-2018

Re: HDMI not work on zcu102 with TRD 2018.2

Jump to solution

Hi Kvasantr,

Thanks for your information, I already ordered one dongle.
I will check it when I receive the dongle.

0 Kudos