UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
1,055 Views
Registered: ‎11-09-2017

Implementing XAPP495 on atlys spartan 6...problem with HDMI out

Jump to solution

Hi, I tried to implement xapp495 fixed from https://joelw.id.au/FPGA/DigilentAtlysResources#Improved_XAPP495

I added all files of DVI_test.v.... and the ucf file for DVI.... But when I uploaded to FPGA.... HDMI out is not showing the output.... Many people have such problem saying that it is an EDID problem... But XAPP495 fixed had resolved EDID problem... and there was no need of connecting JP6/JP7 jumpers...... Attached images will give you a clear picture on what I want to say....

 

Any kind of help would be appreciated a lot..... Thank you

Tags (1)
1.JPG
Capture.JPG
3.JPG
0 Kudos
1 Solution

Accepted Solutions
Moderator
Moderator
1,198 Views
Registered: ‎11-09-2015

Re: Implementing XAPP495 on atlys spartan 6...problem with HDMI out

Jump to solution

Hi @silent.tears95,

 

You might want to try to add a chipscope inside your design to see where the data is stuck. I would start by ensuring the data is correctly getting inside the FPGA.

 

Hope that helps,

 

Regards,

 

Florent


Florent
Product Application Engineer - Xilinx Technical Support EMEA
**~ Don't forget to reply, give kudos, and accept as solution.~**

View solution in original post

0 Kudos
3 Replies
Moderator
Moderator
1,199 Views
Registered: ‎11-09-2015

Re: Implementing XAPP495 on atlys spartan 6...problem with HDMI out

Jump to solution

Hi @silent.tears95,

 

You might want to try to add a chipscope inside your design to see where the data is stuck. I would start by ensuring the data is correctly getting inside the FPGA.

 

Hope that helps,

 

Regards,

 

Florent


Florent
Product Application Engineer - Xilinx Technical Support EMEA
**~ Don't forget to reply, give kudos, and accept as solution.~**

View solution in original post

0 Kudos
868 Views
Registered: ‎11-09-2017

Re: Implementing XAPP495 on atlys spartan 6...problem with HDMI out

Jump to solution

Thank you for your reply. It was a problem with the LCD, I changed the LCD and it started working... I used xapp495 fixed from joelw website..... Thank you very much

0 Kudos
Moderator
Moderator
855 Views
Registered: ‎11-09-2015

Re: Implementing XAPP495 on atlys spartan 6...problem with HDMI out

Jump to solution

Hi @silent.tears95,

 

As your issue is fixed, please close the topic by marking a response as solution.

 

Thanks and Regards,

 

Florent


Florent
Product Application Engineer - Xilinx Technical Support EMEA
**~ Don't forget to reply, give kudos, and accept as solution.~**
0 Kudos