UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Observer maurimum
Observer
3,305 Views
Registered: ‎11-16-2012

Ipcore Image Edge Enhancement and VmodCAM

Hi,

 

Currently I'm trying to implement this core with the VmodCam and Atlys Board, I think that firstly I generate a RGBtoYCrCb core, to work with the Edge filter, but nothing happens with the output signals, so I generate a YCrCbtoRGB, but when the Edge core is connect it doesn't work. Is there a problem with the clock? or what is the correct configuration, I'm using this core as a "constant". I've been working just with  the RGBtoYCrCb and viceverse and it works.

 

Do I have to use a DCM(Clocking Wizzard Core) to control the clocks? or what could be the problem. I hope you can guide me with this topic.

 

thanks.

0 Kudos
3 Replies
Observer maurimum
Observer
3,294 Views
Registered: ‎11-16-2012

Re: Ipcore Image Edge Enhancement and VmodCAM

Hi,

 

Could it be the problem , that I'm using the version 2.0 of Edge?..or Have I to use Axi4 interface?...

 

I hope anybody can help me with this topic, is for my thesis.

 

thanks.

0 Kudos
Highlighted
Observer mustafahyuce
Observer
3,261 Views
Registered: ‎03-29-2013

Re: Ipcore Image Edge Enhancement and VmodCAM

I used the version 2.0 and it works fine.. If you are getting black screen then you should make sure that you are using right clock sources for your core.. i.e if you are trying to use 100MHz clock with this core you will not get any results out.. I believe the pixclk should be your edge enhancement core clock and also you should take in consideration of using hsync and vsync signals as well.

If you want i can send you the bit file that i generated recently and you can try it on your arlys board

Also axi4 interface is to be used with soft core processor if you are not using Microblaze there is no point of using this core i guess
0 Kudos
Observer maurimum
Observer
3,251 Views
Registered: ‎11-16-2012

Re: Ipcore Image Edge Enhancement and VmodCAM

Hi,

 

Could you send me the bit file to try it....about the clock, which one would be correct value, I've been trying to configure a DCM, and which the values of the hsync and vsync signals?..

 

Thanks.

0 Kudos